summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-27 07:52:31 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-27 07:52:31 +0000
commit6805a752e09b229b7d83b224f824d1dd4aee55f6 (patch)
tree9a05bfd2f51138aed6cdb630e910ece66968879f /dev-ruby/hpricot
parentNew package to fill in the twisted suite. (diff)
downloadgentoo-2-6805a752e09b229b7d83b224f824d1dd4aee55f6.tar.gz
gentoo-2-6805a752e09b229b7d83b224f824d1dd4aee55f6.tar.bz2
gentoo-2-6805a752e09b229b7d83b224f824d1dd4aee55f6.zip
Version bump.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hpricot')
-rw-r--r--dev-ruby/hpricot/ChangeLog7
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.5.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/hpricot/ChangeLog b/dev-ruby/hpricot/ChangeLog
index 199b5bd624ee..1275b1edf244 100644
--- a/dev-ruby/hpricot/ChangeLog
+++ b/dev-ruby/hpricot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hpricot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.33 2011/08/07 14:02:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/ChangeLog,v 1.34 2011/12/27 07:52:31 graaff Exp $
+
+*hpricot-0.8.5 (27 Dec 2011)
+
+ 27 Dec 2011; Hans de Graaff <graaff@gentoo.org> +hpricot-0.8.5.ebuild:
+ Version bump.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> hpricot-0.8.4.ebuild,
hpricot-0.8.4-r1.ebuild:
diff --git a/dev-ruby/hpricot/hpricot-0.8.5.ebuild b/dev-ruby/hpricot/hpricot-0.8.5.ebuild
new file mode 100644
index 000000000000..a6fae694ed8e
--- /dev/null
+++ b/dev-ruby/hpricot/hpricot-0.8.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hpricot/hpricot-0.8.5.ebuild,v 1.1 2011/12/27 07:52:31 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fast and liberal HTML parser for Ruby."
+HOMEPAGE="http://wiki.github.com/hpricot/hpricot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# Probably needs the same jdk as JRuby but I'm not sure how to express
+# that just yet.
+DEPEND="${DEPEND}
+ dev-util/ragel
+ ruby_targets_jruby? ( >=virtual/jdk-1.5 )"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "dev-ruby/rake
+ dev-ruby/rake-compiler
+ test? ( virtual/ruby-test-unit )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ # Fix encoding assumption of environment for Ruby 1.9.
+ # https://github.com/hpricot/hpricot/issues/52
+ sed -i -e '1 iEncoding.default_external=Encoding::UTF_8 if RUBY_VERSION =~ /1.9/' test/load_files.rb || die
+}
+
+each_ruby_compile() {
+ case $(basename ${RUBY}) in
+ jruby)
+ ${RUBY} -S rake compile_java || die "rake compile failed"
+ ;;
+ *)
+ ${RUBY} -S rake compile || die "rake compile failed"
+ ;;
+ esac
+}