summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-11 08:42:57 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-11 08:42:57 +0000
commit2beaab3b6d0dc19b4892532621a8439c67383577 (patch)
tree6ee1ff9f815aa7bacb5178728269f3cb64ffbba3 /dev-ruby/hoe/hoe-2.8.0.ebuild
parentRemove old version. (diff)
downloadgentoo-2-2beaab3b6d0dc19b4892532621a8439c67383577.tar.gz
gentoo-2-2beaab3b6d0dc19b4892532621a8439c67383577.tar.bz2
gentoo-2-2beaab3b6d0dc19b4892532621a8439c67383577.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hoe/hoe-2.8.0.ebuild')
-rw-r--r--dev-ruby/hoe/hoe-2.8.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/hoe/hoe-2.8.0.ebuild b/dev-ruby/hoe/hoe-2.8.0.ebuild
new file mode 100644
index 000000000000..d8d90f9181a7
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.8.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.8.0.ebuild,v 1.1 2010/12/11 08:42:57 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( "${P}-test-file-ordering.patch" )
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"