summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-07 20:06:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-07 20:06:58 +0000
commit855cdff2796a7b5100d8ee5e3df7a749a0da969a (patch)
tree29b0224392cc6bde56f34fd3204d1b6d64cf03f2 /dev-ruby/hoe/hoe-2.5.0.ebuild
parentSet empty HOMEPAGE and LICENSE (diff)
downloadgentoo-2-855cdff2796a7b5100d8ee5e3df7a749a0da969a.tar.gz
gentoo-2-855cdff2796a7b5100d8ee5e3df7a749a0da969a.tar.bz2
gentoo-2-855cdff2796a7b5100d8ee5e3df7a749a0da969a.zip
Version bump, rubyforge is no longer needed at runtime either. Tests needed some fixing though.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hoe/hoe-2.5.0.ebuild')
-rw-r--r--dev-ruby/hoe/hoe-2.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/hoe/hoe-2.5.0.ebuild b/dev-ruby/hoe/hoe-2.5.0.ebuild
new file mode 100644
index 000000000000..02bc31ed71c2
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.5.0.ebuild,v 1.1 2010/01/07 20:06:57 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend test "virtual/ruby-minitest >=dev-ruby/rubyforge-2.0.3"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${P}-tests.patch
+}