summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-06-28 18:22:42 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-06-28 18:22:42 +0000
commit156beb8972a1c7a6dc809cdf7820d6e9d9e592c1 (patch)
tree0b734cf437fa9639f7978a5c6425184f079d913d /dev-ruby/hiera
parentVersion bump. (diff)
downloadgentoo-2-156beb8972a1c7a6dc809cdf7820d6e9d9e592c1.tar.gz
gentoo-2-156beb8972a1c7a6dc809cdf7820d6e9d9e592c1.tar.bz2
gentoo-2-156beb8972a1c7a6dc809cdf7820d6e9d9e592c1.zip
bumping dev-ruby/hiera to 1.2.1
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-ruby/hiera')
-rw-r--r--dev-ruby/hiera/ChangeLog7
-rw-r--r--dev-ruby/hiera/hiera-1.2.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/hiera/ChangeLog b/dev-ruby/hiera/ChangeLog
index 6ad21177d0bc..41a5e21fc0e1 100644
--- a/dev-ruby/hiera/ChangeLog
+++ b/dev-ruby/hiera/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hiera
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/ChangeLog,v 1.9 2013/02/03 13:29:43 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/ChangeLog,v 1.10 2013/06/28 18:22:42 prometheanfire Exp $
+
+*hiera-1.2.1 (28 Jun 2013)
+
+ 28 Jun 2013; Matthew Thode <prometheanfire@gentoo.org> +hiera-1.2.1.ebuild:
+ bumping dev-ruby/hiera to 1.2.1
03 Feb 2013; Matthew Thode <prometheanfire@gentoo.org> metadata.xml:
taking maintership
diff --git a/dev-ruby/hiera/hiera-1.2.1.ebuild b/dev-ruby/hiera/hiera-1.2.1.ebuild
new file mode 100644
index 000000000000..09beebc5ef75
--- /dev/null
+++ b/dev-ruby/hiera/hiera-1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hiera/hiera-1.2.1.ebuild,v 1.1 2013/06/28 18:22:42 prometheanfire Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple pluggable Hierarchical Database"
+HOMEPAGE="http://projects.puppetlabs.com/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Our json package is either the compiled version or the pure
+ # version. Fix gemspec accordingly.
+ sed -i -e 's/json_pure/json/' ../metadata || die
+}