summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-22 18:14:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-22 18:14:04 +0000
commitf630bd5c5ef39c58ac9947a23b900c1103d6a039 (patch)
tree533a15e08be910d761f5ebf546670da792abffc3 /dev-ruby/haml
parentFix USE=xen to depend on app-emulation/xen-tools. app-emulation/xen does not ... (diff)
downloadgentoo-2-f630bd5c5ef39c58ac9947a23b900c1103d6a039.tar.gz
gentoo-2-f630bd5c5ef39c58ac9947a23b900c1103d6a039.tar.bz2
gentoo-2-f630bd5c5ef39c58ac9947a23b900c1103d6a039.zip
Unbundle sass from haml; add it as a dependency; bump to EAPI=4.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog8
-rw-r--r--dev-ruby/haml/files/haml-3.1.4-sass.patch22
-rw-r--r--dev-ruby/haml/haml-3.1.4-r2.ebuild56
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index a945c8c9d9eb..3eec565169dd 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.70 2012/01/01 07:45:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.71 2012/01/22 18:14:04 flameeyes Exp $
+
+*haml-3.1.4-r2 (22 Jan 2012)
+
+ 22 Jan 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/haml-3.1.4-sass.patch, +haml-3.1.4-r2.ebuild:
+ Unbundle sass from haml; add it as a dependency; bump to EAPI=4.
*haml-3.1.4-r1 (01 Jan 2012)
diff --git a/dev-ruby/haml/files/haml-3.1.4-sass.patch b/dev-ruby/haml/files/haml-3.1.4-sass.patch
new file mode 100644
index 000000000000..8bf5d153749c
--- /dev/null
+++ b/dev-ruby/haml/files/haml-3.1.4-sass.patch
@@ -0,0 +1,22 @@
+Index: haml-3.1.4/metadata
+===================================================================
+--- haml-3.1.4.orig/metadata
++++ haml-3.1.4/metadata
+@@ -20,6 +20,17 @@ date: 2011-11-28 00:00:00 -08:00
+ default_executable:
+ dependencies:
+ - !ruby/object:Gem::Dependency
++ name: sass
++ prerelease: false
++ requirement: &id003 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - "~>"
++ - !ruby/object:Gem::Version
++ version: 3.1.11
++ type: :runtime
++ version_requirements: *id003
++- !ruby/object:Gem::Dependency
+ name: yard
+ prerelease: false
+ requirement: &id001 !ruby/object:Gem::Requirement
diff --git a/dev-ruby/haml/haml-3.1.4-r2.ebuild b/dev-ruby/haml/haml-3.1.4-r2.ebuild
new file mode 100644
index 000000000000..aac4a5c94c9c
--- /dev/null
+++ b/dev-ruby/haml/haml-3.1.4-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.4-r2.ebuild,v 1.1 2012/01/22 18:14:04 flameeyes Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend "dev-ruby/hpricot dev-ruby/sass"
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"
+
+all_ruby_prepare() {
+ # unbundle sass; remove dependency over fssm and add one over sass
+ # itself.
+ rm -r vendor/ || die
+
+ pushd .. &>/dev/null
+ epatch "${FILESDIR}"/${P}-sass.patch
+ sed -i \
+ -e '/vendor\//d' \
+ metadata || die
+ popd &>/dev/null
+}