summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-08-31 05:16:56 +0000
committerHans de Graaff <graaff@gentoo.org>2013-08-31 05:16:56 +0000
commitf5febbb6f0678f5388264d548aa5e89b8a8d9480 (patch)
treeaedb046b65332727f548455aaf6a0ff6c97c2020 /dev-ruby/haml
parentCleanup. (diff)
downloadgentoo-2-f5febbb6f0678f5388264d548aa5e89b8a8d9480.tar.gz
gentoo-2-f5febbb6f0678f5388264d548aa5e89b8a8d9480.tar.bz2
gentoo-2-f5febbb6f0678f5388264d548aa5e89b8a8d9480.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog6
-rw-r--r--dev-ruby/haml/haml-3.1.6.ebuild55
-rw-r--r--dev-ruby/haml/haml-3.1.8.ebuild61
3 files changed, 5 insertions, 117 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 84ba41ed13e6..042875d669e0 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.85 2013/06/13 11:38:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.86 2013/08/31 05:16:55 graaff Exp $
+
+ 31 Aug 2013; Hans de Graaff <graaff@gentoo.org> -haml-3.1.6.ebuild,
+ -haml-3.1.8.ebuild:
+ Cleanup.
*haml-3.1.8-r1 (13 Jun 2013)
diff --git a/dev-ruby/haml/haml-3.1.6.ebuild b/dev-ruby/haml/haml-3.1.6.ebuild
deleted file mode 100644
index 33aaaaccd8b0..000000000000
--- a/dev-ruby/haml/haml-3.1.6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.6.ebuild,v 1.4 2013/01/16 00:58:44 zerochaos Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails VERSION VERSION_NAME"
-
-inherit ruby-fakegem
-
-DESCRIPTION="HAML - a ruby web page templating engine"
-HOMEPAGE="http://haml-lang.com/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# TODO: haml has some emacs modes that it could be installing, in case
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/sass"
-
-# It could use merb during testing as well, but it's not mandatory
-ruby_add_bdepend "
- test? (
- dev-ruby/hpricot
- dev-ruby/erubis
- dev-ruby/rails
- dev-ruby/ruby_parser
- )
- doc? (
- dev-ruby/yard
- dev-ruby/maruku
- )"
-
-all_ruby_prepare() {
- # unbundle sass; remove dependency over fssm and add one over sass
- # itself.
- rm -r vendor/ || die
-
- pushd .. &>/dev/null
- epatch "${FILESDIR}"/${P}-sass.patch
- sed -i \
- -e '/vendor\//d' \
- metadata || die
- popd &>/dev/null
-}
diff --git a/dev-ruby/haml/haml-3.1.8.ebuild b/dev-ruby/haml/haml-3.1.8.ebuild
deleted file mode 100644
index 6797cfc468be..000000000000
--- a/dev-ruby/haml/haml-3.1.8.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.8.ebuild,v 1.1 2013/03/08 06:39:58 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
-
-RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails VERSION VERSION_NAME"
-
-inherit ruby-fakegem
-
-DESCRIPTION="HAML - a ruby web page templating engine"
-HOMEPAGE="http://haml-lang.com/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# TODO: haml has some emacs modes that it could be installing, in case
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/sass"
-
-# It could use merb during testing as well, but it's not mandatory
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest
- dev-ruby/hpricot
- dev-ruby/erubis
- dev-ruby/rails
- dev-ruby/ruby_parser
- >=dev-ruby/sass-3.2.0
- )
- doc? (
- dev-ruby/yard
- dev-ruby/maruku
- dev-ruby/sass
- )"
-
-all_ruby_prepare() {
- # unbundle sass; remove dependency over fssm and add one over sass
- # itself.
- rm -r vendor/ || die
-
- pushd .. &>/dev/null
- epatch "${FILESDIR}"/${PN}-3.1.6-sass.patch
- sed -i \
- -e '/vendor\//d' \
- metadata || die
- popd &>/dev/null
-
- # Use newer sass and update specs to make a consistent combination.
- sed -i -e 's/fuchsia/magenta/' test/haml/results/filters.xhtml || die
-}