summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-27 05:54:53 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-27 05:54:53 +0000
commite0480ac52e56546c4cd784af8e99a0296f6c4969 (patch)
treea480a28a9f4a80ce6995100b520ce824257e7adf /dev-ruby/haml
parentVersion bump: bug fixes. (diff)
downloadgentoo-2-e0480ac52e56546c4cd784af8e99a0296f6c4969.tar.gz
gentoo-2-e0480ac52e56546c4cd784af8e99a0296f6c4969.tar.bz2
gentoo-2-e0480ac52e56546c4cd784af8e99a0296f6c4969.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-2.2.23.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index d36dfa81315f..0727145c9db9 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.39 2010/04/02 06:37:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.40 2010/04/27 05:54:53 graaff Exp $
+
+*haml-2.2.23 (27 Apr 2010)
+
+ 27 Apr 2010; Hans de Graaff <graaff@gentoo.org> +haml-2.2.23.ebuild:
+ Version bump.
*haml-2.2.22-r1 (02 Apr 2010)
diff --git a/dev-ruby/haml/haml-2.2.23.ebuild b/dev-ruby/haml/haml-2.2.23.ebuild
new file mode 100644
index 000000000000..b40e20ee59b7
--- /dev/null
+++ b/dev-ruby/haml/haml-2.2.23.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-2.2.23.ebuild,v 1.1 2010/04/27 05:54:53 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/haml.gemspec/,/Task\[:package\]/s:^:#:' "${S}"/Rakefile
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # This is needed otherwise it fails at runtime
+ ruby_fakegem_doins VERSION VERSION_NAME
+}
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend test "virtual/ruby-test-unit dev-ruby/actionpack"
+ruby_add_bdepend doc "dev-ruby/yard dev-ruby/maruku"