summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-30 19:17:22 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-30 19:17:22 +0000
commitbef77723edd55da4fcab834e9f3417ab980cf9ca (patch)
treecb88aa977e38a005683d52c0806445c30481be6f /dev-ruby/haml
parentInstall docs. Fix USE=doc failure. Run more tests. (diff)
downloadgentoo-2-bef77723edd55da4fcab834e9f3417ab980cf9ca.tar.gz
gentoo-2-bef77723edd55da4fcab834e9f3417ab980cf9ca.tar.bz2
gentoo-2-bef77723edd55da4fcab834e9f3417ab980cf9ca.zip
Fix tests by adding a dependency on dev-ruby/erubis, bug 326303. Restrict tests in haml-3.0.13 and fix them in -r1. Drop ppc, ppc64 keywords for -r1 due to new dependency: bug 326353.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog10
-rw-r--r--dev-ruby/haml/haml-3.0.13-r1.ebuild41
-rw-r--r--dev-ruby/haml/haml-3.0.13.ebuild4
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 1c02f6f0e696..9ce380a69b80 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.44 2010/06/25 20:06:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.45 2010/06/30 19:17:22 graaff Exp $
+
+*haml-3.0.13-r1 (30 Jun 2010)
+
+ 30 Jun 2010; Hans de Graaff <graaff@gentoo.org> haml-3.0.13.ebuild,
+ +haml-3.0.13-r1.ebuild:
+ Fix tests by adding a dependency on dev-ruby/erubis, bug 326303. Restrict
+ tests in haml-3.0.13 and fix them in -r1. Drop ppc, ppc64 keywords for -r1
+ due to new dependency: bug 326353.
*haml-3.0.13 (25 Jun 2010)
diff --git a/dev-ruby/haml/haml-3.0.13-r1.ebuild b/dev-ruby/haml/haml-3.0.13-r1.ebuild
new file mode 100644
index 000000000000..c4fb3ef8cbc7
--- /dev/null
+++ b/dev-ruby/haml/haml-3.0.13-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.13-r1.ebuild,v 1.1 2010/06/30 19:17:22 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/actionpack
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"
diff --git a/dev-ruby/haml/haml-3.0.13.ebuild b/dev-ruby/haml/haml-3.0.13.ebuild
index 6a704d0aac31..cc18094d6586 100644
--- a/dev-ruby/haml/haml-3.0.13.ebuild
+++ b/dev-ruby/haml/haml-3.0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.13.ebuild,v 1.1 2010/06/25 20:06:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.13.ebuild,v 1.2 2010/06/30 19:17:22 graaff Exp $
EAPI=2
@@ -25,6 +25,8 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
# TODO: haml has some emacs modes that it could be installing, in case
IUSE=""
+RESTRICT="test"
+
# The html engine requires hpricot
ruby_add_rdepend dev-ruby/hpricot