summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-10-07 06:26:10 +0000
committerHans de Graaff <graaff@gentoo.org>2013-10-07 06:26:10 +0000
commitad4681a9f598a247a4e558b105b908f6fcd4eb6a (patch)
treeaa59be2ba8038e2ef1c3ec9b4ed1397fddd34961 /dev-ruby/haml
parentUnmask GCC 4.8. (diff)
downloadgentoo-2-ad4681a9f598a247a4e558b105b908f6fcd4eb6a.tar.gz
gentoo-2-ad4681a9f598a247a4e558b105b908f6fcd4eb6a.tar.bz2
gentoo-2-ad4681a9f598a247a4e558b105b908f6fcd4eb6a.zip
Add a revision and hard blocker to ensure only the latest slot installs in /usr/bin, fixing bug 487142.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog9
-rw-r--r--dev-ruby/haml/haml-3.1.8-r2.ebuild65
-rw-r--r--dev-ruby/haml/haml-4.0.3.ebuild4
3 files changed, 76 insertions, 2 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 65c7bc0248fe..3983b5857bd9 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.88 2013/10/06 15:41:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.89 2013/10/07 06:26:10 graaff Exp $
+
+*haml-3.1.8-r2 (07 Oct 2013)
+
+ 07 Oct 2013; Hans de Graaff <graaff@gentoo.org> +haml-3.1.8-r2.ebuild,
+ haml-4.0.3.ebuild:
+ Add a revision and hard blocker to ensure only the latest slot installs in
+ /usr/bin, fixing bug 487142.
06 Oct 2013; Hans de Graaff <graaff@gentoo.org> haml-3.1.8-r1.ebuild:
Drop tests from stable candidate so we can bootstrap a stable ruby19 rails
diff --git a/dev-ruby/haml/haml-3.1.8-r2.ebuild b/dev-ruby/haml/haml-3.1.8-r2.ebuild
new file mode 100644
index 000000000000..6a62cceba5a5
--- /dev/null
+++ b/dev-ruby/haml/haml-3.1.8-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.8-r2.ebuild,v 1.1 2013/10/07 06:26:10 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails VERSION VERSION_NAME"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+RESTRICT="test"
+
+ruby_add_rdepend "dev-ruby/sass"
+
+# It could use merb during testing as well, but it's not mandatory
+# ruby_add_bdepend "
+# test? (
+# dev-ruby/minitest
+# dev-ruby/hpricot
+# dev-ruby/erubis
+# dev-ruby/rails
+# dev-ruby/ruby_parser
+# >=dev-ruby/sass-3.2.0
+# )"
+ruby_add_bdepend "doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ dev-ruby/sass
+ )"
+
+all_ruby_prepare() {
+ # unbundle sass; remove dependency over fssm and add one over sass
+ # itself.
+ rm -r vendor/ || die
+
+ pushd .. &>/dev/null
+ epatch "${FILESDIR}"/${PN}-3.1.6-sass.patch
+ sed -i \
+ -e '/vendor\//d' \
+ metadata || die
+ popd &>/dev/null
+
+ # Use newer sass and update specs to make a consistent combination.
+ sed -i -e 's/fuchsia/magenta/' test/haml/results/filters.xhtml || die
+}
diff --git a/dev-ruby/haml/haml-4.0.3.ebuild b/dev-ruby/haml/haml-4.0.3.ebuild
index a58618f77f03..2942a7d52b10 100644
--- a/dev-ruby/haml/haml-4.0.3.ebuild
+++ b/dev-ruby/haml/haml-4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-4.0.3.ebuild,v 1.1 2013/10/06 15:38:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-4.0.3.ebuild,v 1.2 2013/10/07 06:26:10 graaff Exp $
EAPI=5
@@ -23,6 +23,8 @@ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-ma
IUSE="doc test"
+RDEPEND="${RDEPEND} !!<dev-ruby/haml-3.1.8-r2"
+
ruby_add_rdepend "dev-ruby/tilt"
ruby_add_bdepend "