summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-02 10:05:32 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-02 10:05:32 +0000
commit791920457d99881e211efa1a72c64e7cbcfef39a (patch)
tree36351a84f4326b1b3237b21a96e74525abe22654 /dev-ruby/haml
parentx86 stable per bug 286999 (diff)
downloadgentoo-2-791920457d99881e211efa1a72c64e7cbcfef39a.tar.gz
gentoo-2-791920457d99881e211efa1a72c64e7cbcfef39a.tar.bz2
gentoo-2-791920457d99881e211efa1a72c64e7cbcfef39a.zip
Version bump.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-3.0.25.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 1c9274d65903..5fc5571f7f68 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.58 2011/01/02 09:48:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.59 2011/01/02 10:05:32 graaff Exp $
+
+*haml-3.0.25 (02 Jan 2011)
+
+ 02 Jan 2011; Hans de Graaff <graaff@gentoo.org> +haml-3.0.25.ebuild:
+ Version bump.
02 Jan 2011; Hans de Graaff <graaff@gentoo.org> -haml-2.2.24.ebuild,
-haml-3.0.21.ebuild, -haml-3.0.22.ebuild, -haml-3.0.23.ebuild:
diff --git a/dev-ruby/haml/haml-3.0.25.ebuild b/dev-ruby/haml/haml-3.0.25.ebuild
new file mode 100644
index 000000000000..2db4785a401f
--- /dev/null
+++ b/dev-ruby/haml/haml-3.0.25.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.25.ebuild,v 1.1 2011/01/02 10:05:32 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"