summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-15 09:48:34 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-15 09:48:34 +0000
commit0f610b2826ca060317f74a451471d6fda0583aa5 (patch)
tree572c0f1ef1b0412f3381e28c9d56f6f563bf1963 /dev-ruby/gherkin
parentAdd ruby19. Make sure to use test-unit:0 with test/spec for ruby19. (diff)
downloadgentoo-2-0f610b2826ca060317f74a451471d6fda0583aa5.tar.gz
gentoo-2-0f610b2826ca060317f74a451471d6fda0583aa5.tar.bz2
gentoo-2-0f610b2826ca060317f74a451471d6fda0583aa5.zip
Version bump.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog9
-rw-r--r--dev-ruby/gherkin/gherkin-2.7.3.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 19642d0bd155..7956f69f0395 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gherkin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.35 2011/12/31 18:11:41 grobian Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.36 2012/01/15 09:48:34 graaff Exp $
+
+*gherkin-2.7.3 (15 Jan 2012)
+
+ 15 Jan 2012; Hans de Graaff <graaff@gentoo.org> +gherkin-2.7.3.ebuild:
+ Version bump.
31 Dec 2011; Fabian Groffen <grobian@gentoo.org> gherkin-1.0.30-r1.ebuild:
Add Prefix keywords, bug #396547
diff --git a/dev-ruby/gherkin/gherkin-2.7.3.ebuild b/dev-ruby/gherkin/gherkin-2.7.3.ebuild
new file mode 100644
index 000000000000..64dc43cc31b0
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.7.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.7.3.ebuild,v 1.1 2012/01/15 09:48:34 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
+HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+RUBY_S="cucumber-gherkin-*"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/awesome_print-0.4.0
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-1.1.3
+ >=dev-ruby/rspec-2.6.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )
+ doc? ( >=dev-ruby/yard-0.7.4 )"
+
+ruby_add_rdepend ">=dev-ruby/json-1.4.6"
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove these tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet. Also remove other rake tasks for which we may not yet have
+ # dependencies.
+ if ! use test ; then
+ rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
+}