summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2009-03-21 18:56:10 +0000
committerMatti Bickel <mabi@gentoo.org>2009-03-21 18:56:10 +0000
commit890492269620d05e939191f3e8af9d09ea9cdaed (patch)
treea5b8a85957779b89599a0a68c02a291ed5a7dcbf /dev-ruby/fxruby
parentamd64 stable, bug 248220 (diff)
downloadgentoo-2-890492269620d05e939191f3e8af9d09ea9cdaed.tar.gz
gentoo-2-890492269620d05e939191f3e8af9d09ea9cdaed.tar.bz2
gentoo-2-890492269620d05e939191f3e8af9d09ea9cdaed.zip
version bump, cleanup
(Portage version: 2.1.6.9/cvs/Linux ppc)
Diffstat (limited to 'dev-ruby/fxruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog8
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.19.ebuild (renamed from dev-ruby/fxruby/fxruby-1.6.18.ebuild)38
2 files changed, 42 insertions, 4 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
index 949d5a740030..6aa8b8165293 100644
--- a/dev-ruby/fxruby/ChangeLog
+++ b/dev-ruby/fxruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/fxruby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.72 2009/01/04 16:32:49 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.73 2009/03/21 18:56:10 mabi Exp $
+
+*fxruby-1.6.19 (21 Mar 2009)
+
+ 21 Mar 2009; Matti Bickel <mabi@gentoo.org> -fxruby-1.6.18.ebuild,
+ +fxruby-1.6.19.ebuild:
+ version bump, cleanup
*fxruby-1.6.18-r1 (04 Jan 2009)
diff --git a/dev-ruby/fxruby/fxruby-1.6.18.ebuild b/dev-ruby/fxruby/fxruby-1.6.19.ebuild
index 3ab99dd10460..e16ecc788fe0 100644
--- a/dev-ruby/fxruby/fxruby-1.6.18.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.6.19.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.18.ebuild,v 1.4 2009/01/04 16:32:49 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.19.ebuild,v 1.1 2009/03/21 18:56:10 mabi Exp $
+
+EAPI="1"
RUBY_BUG_145222=yes
inherit ruby
@@ -16,7 +18,7 @@ SLOT="1.6"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples doc"
-DEPEND="=x11-libs/fox-1.6*
+DEPEND="x11-libs/fox:1.6
>=x11-libs/fxscintilla-1.62-r1"
USE_RUBY="ruby18 ruby19"
@@ -38,5 +40,35 @@ src_install() {
${RUBY_ECONF} || die "install.rb config failed"
${RUBY} install.rb install "$@" --prefix="${D}" \
- ${RUBY_ECONF} || die "install.rb install failed"
+ ${RUBY_ECONF} || die "install.rb install failed"
+
+ # from ruby.eclass, but with use flag control
+ if use doc; then
+ local rdbase=/usr/share/doc/${PF}/rd rdfiles=$(find . -name '*.rd*')
+
+ einfo "running dodoc for ruby ;)"
+
+ insinto ${rdbase}
+ [ -n "${rdfiles}" ] && doins ${rdfiles}
+ rmdir ${D}${rdbase} 2>/dev/null || true
+ if [ -d doc -o -d docs ] ; then
+ dohtml -x html -r {doc,docs}/*
+ dohtml -r {doc,docs}/html/*
+ else
+ dohtml -r *
+ fi
+
+ for i in ChangeLog* [[:upper:]][[:upper:]]* ; do
+ [ -e $i ] && dodoc $i
+ done
+ fi
+
+ if use examples; then
+ for dir in sample samples example examples; do
+ if [ -d ${dir} ] ; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR ${dir} ${D}/usr/share/doc/${PF} || die "cp failed"
+ fi
+ done
+ fi
}