summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-05-28 05:05:16 +0000
committerHans de Graaff <graaff@gentoo.org>2015-05-28 05:05:16 +0000
commit2e1cc02eb88416cfc093bbbf2443bdea9b1f34d6 (patch)
treeda4c3ef2d62f06ef6fdb4eff8b25ebc2346e549c /dev-ruby/fxruby
parentStable for HPPA PPC64 (bug #543930). (diff)
downloadgentoo-2-2e1cc02eb88416cfc093bbbf2443bdea9b1f34d6.tar.gz
gentoo-2-2e1cc02eb88416cfc093bbbf2443bdea9b1f34d6.tar.bz2
gentoo-2-2e1cc02eb88416cfc093bbbf2443bdea9b1f34d6.zip
Create stable candidate.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/fxruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog8
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild77
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.29.ebuild4
3 files changed, 86 insertions, 3 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
index 0eaca1d92496..fdcd1823aee2 100644
--- a/dev-ruby/fxruby/ChangeLog
+++ b/dev-ruby/fxruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/fxruby
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.119 2015/03/20 14:22:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.120 2015/05/28 05:05:16 graaff Exp $
+
+*fxruby-1.6.29-r1 (28 May 2015)
+
+ 28 May 2015; Hans de Graaff <graaff@gentoo.org> fxruby-1.6.29.ebuild,
+ +fxruby-1.6.29-r1.ebuild:
+ Create stable candidate.
20 Mar 2015; Hans de Graaff <graaff@gentoo.org> fxruby-1.6.29.ebuild:
Document problems with ruby22.
diff --git a/dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild b/dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild
new file mode 100644
index 000000000000..abc4dc8d629f
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.29-r1.ebuild,v 1.1 2015/05/28 05:05:16 graaff Exp $
+
+EAPI=5
+# ruby22 -> fails tests
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_NAME="fxruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt index.html README.rdoc TODO"
+
+inherit multilib virtualx ruby-fakegem toolchain-funcs
+
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="examples doc"
+
+CDEPEND="x11-libs/fox:1.6 >=x11-libs/fxscintilla-1.62-r1"
+DEPEND="${DEPEND} ${CDEPEND} dev-lang/swig"
+RDEPEND="${RDEPEND} ${CDEPEND}"
+
+ruby_add_bdepend "test? ( dev-ruby/ruby-opengl )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ sed -i -e '/\[:compile\]/d' Rakefile || die
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -I:-I:' \
+ ext/fox16_c/extconf.rb || die "Can't fix forced -O0"
+
+ # Use a more modern swig.
+ sed -i -e 's/swig-1.3.22/swig/g' Rakefile || die
+
+ # Remove failing tests. We did not run tests before so this is not a
+ # regression for now.
+ rm test/TC_FXFileStream.rb test/TC_FXId.rb test/TC_FXMainWindow.rb test/TC_FXMaterial.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fox16_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ CXX=$(tc-getCXX) emake V=1 -Cext/fox16_c || die
+ cp ext/fox16_c/fox16_c$(get_modname) lib/ || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --main rdoc-sources/README.rdoc --exclude ext/fox16_c --exclude "/aliases|kwargs|missingdep|responder/" || die
+}
+
+each_ruby_test() {
+ VIRTUALX_COMMAND=${RUBY} virtualmake -S testrb -Ilib test/TC_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ for dir in sample samples example examples; do
+ if [ -d ${dir} ] ; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR ${dir} "${D}"/usr/share/doc/${PF} || die "cp failed"
+ fi
+ done
+ fi
+}
diff --git a/dev-ruby/fxruby/fxruby-1.6.29.ebuild b/dev-ruby/fxruby/fxruby-1.6.29.ebuild
index c105d7afd364..18c410dc360c 100644
--- a/dev-ruby/fxruby/fxruby-1.6.29.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.6.29.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.29.ebuild,v 1.2 2015/03/20 14:22:52 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.29.ebuild,v 1.3 2015/05/28 05:05:16 graaff Exp $
EAPI=5
# ruby22 -> fails tests
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_NAME="fxruby"