summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-09 22:10:13 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-09 22:10:13 +0000
commitc660c0afff06b9c757c21c4e92979516b3aa3f95 (patch)
tree4226460cc7d1fe243f778f5c0ac37e8d8e381819 /dev-ruby/ffi/ffi-1.9.6.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c660c0afff06b9c757c21c4e92979516b3aa3f95.tar.gz
gentoo-2-c660c0afff06b9c757c21c4e92979516b3aa3f95.tar.bz2
gentoo-2-c660c0afff06b9c757c21c4e92979516b3aa3f95.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ffi/ffi-1.9.6.ebuild')
-rw-r--r--dev-ruby/ffi/ffi-1.9.6.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-ruby/ffi/ffi-1.9.6.ebuild b/dev-ruby/ffi/ffi-1.9.6.ebuild
new file mode 100644
index 000000000000..5cb8ef5afa30
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.9.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ffi/ffi-1.9.6.ebuild,v 1.1 2014/10/09 22:10:13 mrueg Exp $
+
+EAPI=5
+
+# jruby → unneeded, this is part of the standard JRuby distribution, and
+# would just install a dummy.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="http://wiki.github.com/ffi/ffi"
+
+SRC_URI="http://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+RDEPEND+=" virtual/libffi"
+DEPEND+=" virtual/libffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+ruby_add_rdepend "virtual/ruby-threads"
+
+all_ruby_prepare() {
+ sed -i -e '/tasks/ s:^:#:' \
+ -e '/Gem::Tasks/,/end/ s:^:#:' Rakefile || die
+
+ # Fix Makefile for tests
+ sed -i -e '/CCACHE :=/ s:^:#:' \
+ -e 's/-O2//' \
+ -e 's/^CFLAGS =/CFLAGS +=/' libtest/GNUmakefile || die
+
+ # Remove bundled version of libffi.
+ rm -rf ext/ffi_c/libffi || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ffi_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ffi_c V=1
+ cp ext/ffi_c/ffi_c.so lib/ || die
+
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+each_ruby_test() {
+ CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${RUBY} -S rspec spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}