summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-06-22 18:59:29 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-06-22 18:59:29 +0000
commit1e60a6eb38635f8cfd185f10bc5a98f43e5195a9 (patch)
tree91d5d3203e38522c0c3077e3f8316e9ed1eb9b11 /dev-ruby/facter
parentVersion bump (diff)
downloadgentoo-2-1e60a6eb38635f8cfd185f10bc5a98f43e5195a9.tar.gz
gentoo-2-1e60a6eb38635f8cfd185f10bc5a98f43e5195a9.tar.bz2
gentoo-2-1e60a6eb38635f8cfd185f10bc5a98f43e5195a9.zip
needs to be stablized for bug 514476 CVE-2014-32[48,50]
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/ChangeLog7
-rw-r--r--dev-ruby/facter/facter-1.7.6.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/facter/ChangeLog b/dev-ruby/facter/ChangeLog
index 3a835f7fdbf6..40535bc1d1f5 100644
--- a/dev-ruby/facter/ChangeLog
+++ b/dev-ruby/facter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/facter
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.95 2014/06/15 03:29:57 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.96 2014/06/22 18:59:29 prometheanfire Exp $
+
+*facter-1.7.6 (22 Jun 2014)
+
+ 22 Jun 2014; Matthew Thode <prometheanfire@gentoo.org> +facter-1.7.6.ebuild:
+ needs to be stablized for bug 514476 CVE-2014-32[48,50]
*facter-2.0.2 (15 Jun 2014)
diff --git a/dev-ruby/facter/facter-1.7.6.ebuild b/dev-ruby/facter/facter-1.7.6.ebuild
new file mode 100644
index 000000000000..33277b40af29
--- /dev/null
+++ b/dev-ruby/facter/facter-1.7.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.7.6.ebuild,v 1.1 2014/06/22 18:59:29 prometheanfire Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 jruby"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="facter"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+dmi +pciutils"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ sys-apps/net-tools
+ sys-apps/lsb-release
+ dmi? ( sys-apps/dmidecode )
+ pciutils? ( sys-apps/pciutils )"
+
+RDEPEND+=" ${CDEPEND}"
+DEPEND+=" test? ( ${CDEPEND} )"
+
+RUBY_PATCHES=( )
+
+ruby_add_bdepend "test? ( >=dev-ruby/mocha-0.10.5:0.10 )"
+
+all_ruby_prepare() {
+ # Provide explicit path since /sbin is not in the default PATH on
+ # Gentoo.
+ sed -i -e 's:arp -an:/sbin/arp -an:' lib/facter/util/ec2.rb spec/unit/util/ec2_spec.rb || die
+
+ # Ensure the correct version of mocha is used without using bundler.
+ sed -i -e '9igem "mocha", "~>0.10.5"' spec/spec_helper.rb || die
+}