summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-02 05:24:56 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-02 05:24:56 +0000
commitb29559daedc1a89baf283a9ccc2a8aa9b68120c3 (patch)
treeb8b9c4f0f25be35c1c62ba1ca5b1fd8cf4088b44 /dev-ruby/eventmachine
parentBump (diff)
downloadgentoo-2-b29559daedc1a89baf283a9ccc2a8aa9b68120c3.tar.gz
gentoo-2-b29559daedc1a89baf283a9ccc2a8aa9b68120c3.tar.bz2
gentoo-2-b29559daedc1a89baf283a9ccc2a8aa9b68120c3.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/eventmachine')
-rw-r--r--dev-ruby/eventmachine/ChangeLog7
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.3.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/eventmachine/ChangeLog b/dev-ruby/eventmachine/ChangeLog
index 44dc915af790..e984c1d205c2 100644
--- a/dev-ruby/eventmachine/ChangeLog
+++ b/dev-ruby/eventmachine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/eventmachine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/ChangeLog,v 1.19 2013/01/01 09:03:52 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/ChangeLog,v 1.20 2013/05/02 05:24:56 graaff Exp $
+
+*eventmachine-1.0.3 (02 May 2013)
+
+ 02 May 2013; Hans de Graaff <graaff@gentoo.org> +eventmachine-1.0.3.ebuild:
+ Version bump.
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> eventmachine-0.12.10-r2.ebuild:
Stable for x86, wrt bug #448672
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild
new file mode 100644
index 000000000000..e921c137f593
--- /dev/null
+++ b/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3.ebuild,v 1.1 2013/05/02 05:24:56 graaff Exp $
+
+EAPI=5
+# jruby → has shims for Java handling but tests fail badly, remaining
+# stuck; avoid that for now.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs."
+HOMEPAGE="http://rubyeventmachine.com"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-libs/openssl"
+RDEPEND="${RDEPEND}
+ dev-libs/openssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Remove package tasks to avoid dependency on rake-compiler.
+ rm rakelib/package.rake || die
+
+ # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
+ sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
+
+ # Remove the resolver tests since they require network access and
+ # the localhost test fails with an IPv6 localhost.
+ rm tests/test_resolver.rb || die
+}
+
+each_ruby_configure() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
+ popd
+ done
+}
+
+each_ruby_compile() {
+ for extdir in ext ext/fastfilereader; do
+ pushd $extdir
+ # both extensions use C++, so use the CXXFLAGS not the CFLAGS
+ emake CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
+ popd
+ cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
+ done
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}