summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-15 09:03:58 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-15 09:03:58 +0000
commit494a3e7823487f12e58652580843d5deb9d8edfe (patch)
tree1b2af8eab4235fbf2e083b918e09ce0efc73d7d2 /dev-ruby/diff-lcs/diff-lcs-1.1.3.ebuild
parentVersion bump thanks to elvis4526 for the hint and Agostino Sarubbo for the pa... (diff)
downloadgentoo-2-494a3e7823487f12e58652580843d5deb9d8edfe.tar.gz
gentoo-2-494a3e7823487f12e58652580843d5deb9d8edfe.tar.bz2
gentoo-2-494a3e7823487f12e58652580843d5deb9d8edfe.zip
Version bump. Drop alpha keyword due to new rspec:2 dependency, bug 387179.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/diff-lcs/diff-lcs-1.1.3.ebuild')
-rw-r--r--dev-ruby/diff-lcs/diff-lcs-1.1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/diff-lcs/diff-lcs-1.1.3.ebuild b/dev-ruby/diff-lcs/diff-lcs-1.1.3.ebuild
new file mode 100644
index 000000000000..e78a277d9e83
--- /dev/null
+++ b/dev-ruby/diff-lcs/diff-lcs-1.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/diff-lcs/diff-lcs-1.1.3.ebuild,v 1.1 2011/10/15 09:03:58 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use the McIlroy-Hunt LCS algorithm to compute differences"
+HOMEPAGE="https://github.com/halostatue/diff-lcs"
+
+LICENSE="|| ( MIT Ruby GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/hoe-2.10 dev-ruby/rspec:2 )"