summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-18 04:49:24 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-18 04:49:24 +0000
commit856b628d50e9b9966db2c9acbf35f5fb53dde4f6 (patch)
treeab799c165b3c8214f4292dbfc8b32c778a02fcd2 /dev-ruby/daemons
parentRemove old versions. (diff)
downloadgentoo-2-856b628d50e9b9966db2c9acbf35f5fb53dde4f6.tar.gz
gentoo-2-856b628d50e9b9966db2c9acbf35f5fb53dde4f6.tar.bz2
gentoo-2-856b628d50e9b9966db2c9acbf35f5fb53dde4f6.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/daemons')
-rw-r--r--dev-ruby/daemons/ChangeLog7
-rw-r--r--dev-ruby/daemons/daemons-1.1.4.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ruby/daemons/ChangeLog b/dev-ruby/daemons/ChangeLog
index 145a56dfe955..586d232a8bc7 100644
--- a/dev-ruby/daemons/ChangeLog
+++ b/dev-ruby/daemons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/daemons
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.56 2011/06/18 04:45:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.57 2011/06/18 04:49:24 graaff Exp $
+
+*daemons-1.1.4 (18 Jun 2011)
+
+ 18 Jun 2011; Hans de Graaff <graaff@gentoo.org> +daemons-1.1.4.ebuild:
+ Version bump.
18 Jun 2011; Hans de Graaff <graaff@gentoo.org> -daemons-1.1.0-r1.ebuild,
-daemons-1.1.2.ebuild:
diff --git a/dev-ruby/daemons/daemons-1.1.4.ebuild b/dev-ruby/daemons/daemons-1.1.4.ebuild
new file mode 100644
index 000000000000..79da291d7592
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.4.ebuild,v 1.1 2011/06/18 04:49:24 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
+RUBY_FAKEGEM_DOCDIR="html"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="http://daemons.rubyforge.org/"
+
+LICENSE="|| ( Ruby GPL-2 ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}