summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 01:21:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 01:21:39 +0000
commit1ac49769e3722f46119336247671dae6c48f97ba (patch)
tree990ae12ef2b3cf9bc5321976eb933bf022161796 /dev-ruby/crack
parentInitial import of (mcmire-)matchy, needed for crack's testsuite. (diff)
downloadgentoo-2-1ac49769e3722f46119336247671dae6c48f97ba.tar.gz
gentoo-2-1ac49769e3722f46119336247671dae6c48f97ba.tar.bz2
gentoo-2-1ac49769e3722f46119336247671dae6c48f97ba.zip
Version bump, introduce tests and enable for jruby.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/crack')
-rw-r--r--dev-ruby/crack/ChangeLog7
-rw-r--r--dev-ruby/crack/crack-0.1.5.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/crack/ChangeLog b/dev-ruby/crack/ChangeLog
index 290f548b4beb..17f84984ef6d 100644
--- a/dev-ruby/crack/ChangeLog
+++ b/dev-ruby/crack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/crack
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/ChangeLog,v 1.7 2010/01/11 12:21:57 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/ChangeLog,v 1.8 2010/01/28 01:21:39 flameeyes Exp $
+
+*crack-0.1.5 (28 Jan 2010)
+
+ 28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> +crack-0.1.5.ebuild:
+ Version bump, introduce tests and enable for jruby.
*crack-0.1.4-r1 (11 Jan 2010)
diff --git a/dev-ruby/crack/crack-0.1.5.ebuild b/dev-ruby/crack/crack-0.1.5.ebuild
new file mode 100644
index 000000000000..c3ad6e11b42f
--- /dev/null
+++ b/dev-ruby/crack/crack-0.1.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/crack-0.1.5.ebuild,v 1.1 2010/01/28 01:21:39 flameeyes Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Really simple JSON and XML parsing, ripped from Merb and Rails."
+HOMEPAGE="http://rubyforge.org/projects/crack"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend test "dev-ruby/shoulda dev-ruby/matchy"
+
+all_ruby_prepare() {
+ # By default this gem wants to use the fork of matchy from the
+ # same author of itself, but we don't package that (as it's
+ # neither released on gemcutter nor tagged). On the other hand it
+ # works fine with the mcmire gem that we package as
+ # dev-ruby/matchy.
+ sed -i -e 's:jnunemaker-matchy:mcmire-matchy:' test/test_helper.rb || die
+}