summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-23 18:00:15 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-23 18:00:15 +0000
commit492c06989719ddce59bb026d51fc296eaf572bac (patch)
tree34d26e1b24878f69ecbf853171b80895badc5e42 /dev-ruby/crack/crack-0.1.6.ebuild
parent[sci-chemistry/vmd] add tachyon raytracer as rdep (diff)
downloadgentoo-2-492c06989719ddce59bb026d51fc296eaf572bac.tar.gz
gentoo-2-492c06989719ddce59bb026d51fc296eaf572bac.tar.bz2
gentoo-2-492c06989719ddce59bb026d51fc296eaf572bac.zip
Resurrected crack-0.1.6 because httparty explicitly depends on it.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/crack/crack-0.1.6.ebuild')
-rw-r--r--dev-ruby/crack/crack-0.1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/crack/crack-0.1.6.ebuild b/dev-ruby/crack/crack-0.1.6.ebuild
new file mode 100644
index 000000000000..d3981d0f133b
--- /dev/null
+++ b/dev-ruby/crack/crack-0.1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/crack/crack-0.1.6.ebuild,v 1.3 2010/02/23 18:00:15 graaff Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Really simple JSON and XML parsing, ripped from Merb and Rails."
+HOMEPAGE="http://rubyforge.org/projects/crack"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend test "dev-ruby/shoulda dev-ruby/matchy"
+
+all_ruby_prepare() {
+ # By default this gem wants to use the fork of matchy from the
+ # same author of itself, but we don't package that (as it's
+ # neither released on gemcutter nor tagged). On the other hand it
+ # works fine with the mcmire gem that we package as
+ # dev-ruby/matchy.
+ sed -i -e 's:jnunemaker-matchy:mcmire-matchy:' test/test_helper.rb || die
+}