summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-18 07:16:33 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-18 07:16:33 +0000
commitb733f32e3b4a3578ec4aebf9950441897f3aea24 (patch)
tree05594398f708a9e71a354bbff72e4b4e712b1261 /dev-ruby/coderay
parentVersion bump. (diff)
downloadgentoo-2-b733f32e3b4a3578ec4aebf9950441897f3aea24.tar.gz
gentoo-2-b733f32e3b4a3578ec4aebf9950441897f3aea24.tar.bz2
gentoo-2-b733f32e3b4a3578ec4aebf9950441897f3aea24.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/ChangeLog7
-rw-r--r--dev-ruby/coderay/coderay-1.0.8.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index a087ce7f9efd..7fc0fa333219 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.59 2012/08/14 19:03:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.60 2012/10/18 07:16:33 graaff Exp $
+
+*coderay-1.0.8 (18 Oct 2012)
+
+ 18 Oct 2012; Hans de Graaff <graaff@gentoo.org> +coderay-1.0.8.ebuild:
+ Version bump.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata.xml so that it's the same as most other packages.
diff --git a/dev-ruby/coderay/coderay-1.0.8.ebuild b/dev-ruby/coderay/coderay-1.0.8.ebuild
new file mode 100644
index 000000000000..eb40ca3b172d
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-1.0.8.ebuild,v 1.1 2012/10/18 07:16:33 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/tarball/v${PV} -> ${P}.tgz"
+
+RUBY_S="rubychan-coderay-*"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( >=dev-ruby/redcloth-4.2.2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/ s:^:#:' coderay.gemspec || die
+}