summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-11-26 12:09:12 +0000
committerHans de Graaff <graaff@gentoo.org>2010-11-26 12:09:12 +0000
commit9068c1c17b2071b4e6864cfeaf22e08101beaa0a (patch)
tree10f13ddac4ce50146068beee2598989b7b381179 /dev-ruby/coderay
parentVersion bump. (diff)
downloadgentoo-2-9068c1c17b2071b4e6864cfeaf22e08101beaa0a.tar.gz
gentoo-2-9068c1c17b2071b4e6864cfeaf22e08101beaa0a.tar.bz2
gentoo-2-9068c1c17b2071b4e6864cfeaf22e08101beaa0a.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/ChangeLog7
-rw-r--r--dev-ruby/coderay/coderay-0.9.6.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ruby/coderay/ChangeLog b/dev-ruby/coderay/ChangeLog
index 713cc824477d..bf9adc2a57ad 100644
--- a/dev-ruby/coderay/ChangeLog
+++ b/dev-ruby/coderay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/coderay
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.24 2010/11/01 19:14:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/ChangeLog,v 1.25 2010/11/26 12:09:11 graaff Exp $
+
+*coderay-0.9.6 (26 Nov 2010)
+
+ 26 Nov 2010; Hans de Graaff <graaff@gentoo.org> +coderay-0.9.6.ebuild:
+ Version bump.
01 Nov 2010; Hans de Graaff <graaff@gentoo.org> -coderay-0.9.3.ebuild,
-coderay-0.9.4.ebuild:
diff --git a/dev-ruby/coderay/coderay-0.9.6.ebuild b/dev-ruby/coderay/coderay-0.9.6.ebuild
new file mode 100644
index 000000000000..82f952bf3e1a
--- /dev/null
+++ b/dev-ruby/coderay/coderay-0.9.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coderay/coderay-0.9.6.ebuild,v 1.1 2010/11/26 12:09:12 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="lib/README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting."
+HOMEPAGE="http://coderay.rubychan.de/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Redcloth is optional but automagically tested, so we add this
+# dependency to ensure that we get at least a version that works: bug
+# 330621. We use this convoluted way because redcloth isn't available
+# yet for jruby.
+USE_RUBY=ruby18 ruby_add_bdepend "ruby_targets_ruby18 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ruby19 ruby_add_bdepend "ruby_targets_ruby19 test" ">=dev-ruby/redcloth-4.2.2"
+USE_RUBY=ree18 ruby_add_bdepend "ruby_targets_ree18 test" ">=dev-ruby/redcloth-4.2.2"