summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-16 12:53:52 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-16 12:53:52 +0000
commitcd0bd718e54a69fb7f842c80c4683c1ea56e3fc2 (patch)
treeeac7c58f7fae87697b9705f2bf4b0c1dd0802732 /dev-ruby/classifier-reborn
parentRemoved vulnerable versions (diff)
downloadgentoo-2-cd0bd718e54a69fb7f842c80c4683c1ea56e3fc2.tar.gz
gentoo-2-cd0bd718e54a69fb7f842c80c4683c1ea56e3fc2.tar.bz2
gentoo-2-cd0bd718e54a69fb7f842c80c4683c1ea56e3fc2.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/classifier-reborn')
-rw-r--r--dev-ruby/classifier-reborn/ChangeLog7
-rw-r--r--dev-ruby/classifier-reborn/classifier-reborn-2.0.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/classifier-reborn/ChangeLog b/dev-ruby/classifier-reborn/ChangeLog
index baf2a7c310fe..e1bc2d3c5751 100644
--- a/dev-ruby/classifier-reborn/ChangeLog
+++ b/dev-ruby/classifier-reborn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/classifier-reborn
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/classifier-reborn/ChangeLog,v 1.2 2014/08/13 16:38:40 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/classifier-reborn/ChangeLog,v 1.3 2014/08/16 12:53:52 mrueg Exp $
+
+*classifier-reborn-2.0.1 (16 Aug 2014)
+
+ 16 Aug 2014; Manuel Rüger <mrueg@gentoo.org> +classifier-reborn-2.0.1.ebuild:
+ Version bump.
13 Aug 2014; Manuel Rüger <mrueg@gentoo.org> classifier-reborn-2.0.0.ebuild:
Add hardblocker on dev-ruby/classifier.
diff --git a/dev-ruby/classifier-reborn/classifier-reborn-2.0.1.ebuild b/dev-ruby/classifier-reborn/classifier-reborn-2.0.1.ebuild
new file mode 100644
index 000000000000..26d44da97990
--- /dev/null
+++ b/dev-ruby/classifier-reborn/classifier-reborn-2.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/classifier-reborn/classifier-reborn-2.0.1.ebuild,v 1.1 2014/08/16 12:53:52 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="https://github.com/jekyll/classifier-reborn"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier
+ gsl? ( dev-ruby/rb-gsl )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/' -i lib/${PN}/lsi.rb || die
+ fi
+}