summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-03-13 07:17:08 +0000
committerHans de Graaff <graaff@gentoo.org>2011-03-13 07:17:08 +0000
commit56f85ad22d784ad63470d9bb645f16b6a0d8eef4 (patch)
treecfab219bb022ebf8e91d0f0d5e8d2fffb984a15e /dev-ruby/bluecloth
parentdrop unneeded dep to gnome-base/libgnomeprint (bug #358441) (diff)
downloadgentoo-2-56f85ad22d784ad63470d9bb645f16b6a0d8eef4.tar.gz
gentoo-2-56f85ad22d784ad63470d9bb645f16b6a0d8eef4.tar.bz2
gentoo-2-56f85ad22d784ad63470d9bb645f16b6a0d8eef4.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/bluecloth')
-rw-r--r--dev-ruby/bluecloth/ChangeLog7
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.1.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index 8083a756363a..8c80801b0c8d 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.42 2011/03/08 11:04:37 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.43 2011/03/13 07:17:08 graaff Exp $
+
+*bluecloth-2.1.0 (13 Mar 2011)
+
+ 13 Mar 2011; Hans de Graaff <graaff@gentoo.org> +bluecloth-2.1.0.ebuild:
+ Version bump.
08 Mar 2011; Thomas Kahle <tomka@gentoo.org> bluecloth-2.0.11.ebuild:
keyworded ~x86 per bug 354435
diff --git a/dev-ruby/bluecloth/bluecloth-2.1.0.ebuild b/dev-ruby/bluecloth/bluecloth-2.1.0.ebuild
new file mode 100644
index 000000000000..1770eb6048e7
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.1.0.ebuild,v 1.1 2011/03/13 07:17:08 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/rspec-2.4:2
+ dev-ruby/diff-lcs
+ dev-ruby/tidy-ext
+ )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 compatibility
+ sed -i -e '1i $: << "."' Rakefile || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "extension build failed"
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die "tests failed"
+}