summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-23 18:45:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-23 18:45:05 +0000
commita8cd0578be2f5a6717eb3f7fd90de597c5daba74 (patch)
tree343a4b3880c627c3c39a62f21eeb54c5a18e22a4 /dev-ruby/best_in_place
parentversion bump (diff)
downloadgentoo-2-a8cd0578be2f5a6717eb3f7fd90de597c5daba74.tar.gz
gentoo-2-a8cd0578be2f5a6717eb3f7fd90de597c5daba74.tar.bz2
gentoo-2-a8cd0578be2f5a6717eb3f7fd90de597c5daba74.zip
Version bump; Gentoo patching is still necessary.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/best_in_place')
-rw-r--r--dev-ruby/best_in_place/ChangeLog8
-rw-r--r--dev-ruby/best_in_place/best_in_place-1.0.5.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/best_in_place/ChangeLog b/dev-ruby/best_in_place/ChangeLog
index e165d755ace8..229dc07378ab 100644
--- a/dev-ruby/best_in_place/ChangeLog
+++ b/dev-ruby/best_in_place/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/best_in_place
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.2 2012/01/21 13:27:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/ChangeLog,v 1.3 2012/01/23 18:45:05 flameeyes Exp $
+
+*best_in_place-1.0.5 (23 Jan 2012)
+
+ 23 Jan 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +best_in_place-1.0.5.ebuild:
+ Version bump; Gentoo patching is still necessary.
*best_in_place-1.0.4-r1 (21 Jan 2012)
diff --git a/dev-ruby/best_in_place/best_in_place-1.0.5.ebuild b/dev-ruby/best_in_place/best_in_place-1.0.5.ebuild
new file mode 100644
index 000000000000..dffd61924814
--- /dev/null
+++ b/dev-ruby/best_in_place/best_in_place-1.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/best_in_place/best_in_place-1.0.5.ebuild,v 1.1 2012/01/23 18:45:05 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="bernat"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit virtualx ruby-fakegem
+
+DESCRIPTION="In-place editor helper for Rails 3o"
+HOMEPAGE="http://github.com/bernat/best_in_place"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/rails:3.1
+ dev-ruby/jquery-rails
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec-rails
+ >=dev-ruby/nokogiri-1.5.0
+ >=dev-ruby/capybara-1.0.1
+ >=dev-ruby/sqlite3-ruby-1.3.4-r1
+ dev-ruby/rdiscount
+ )"
+
+DEPEND+=" test? ( www-client/firefox )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/rspec-rails/s:,.*::' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ rm test_app/Gemfile.lock
+
+ # improve timing-resilience on two tests that would otherwise fail
+ # https://github.com/bernat/best_in_place/issues/87
+ # fix an issue with the :display_as option, that has been sent upstream
+ epatch "${FILESDIR}"/${PN}-1.0.4-gentoo.patch
+}
+
+each_ruby_test() {
+ RAILS_ENV=test ${RUBY} -C test_app -S rake db:migrate || die "test_app migration failed"
+ VIRTUALX_COMMAND="${RUBY}" virtualmake -S rake spec || die "Specs failed"
+}