summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-14 17:59:20 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-14 17:59:20 +0000
commit98fbd4d96d218b2ce51e37c9fc607420d298ee57 (patch)
treeb3dd987c322ace95404975dc525aa6a6c4beccfb /dev-ruby/bcrypt-ruby
parentVersion bump. (diff)
downloadgentoo-2-98fbd4d96d218b2ce51e37c9fc607420d298ee57.tar.gz
gentoo-2-98fbd4d96d218b2ce51e37c9fc607420d298ee57.tar.bz2
gentoo-2-98fbd4d96d218b2ce51e37c9fc607420d298ee57.zip
Remove unused code triggering unused symbols, bug 469690.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/bcrypt-ruby')
-rw-r--r--dev-ruby/bcrypt-ruby/ChangeLog6
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.0.1.ebuild6
-rw-r--r--dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch42
3 files changed, 51 insertions, 3 deletions
diff --git a/dev-ruby/bcrypt-ruby/ChangeLog b/dev-ruby/bcrypt-ruby/ChangeLog
index b8590f22c3b4..dbaa04f34445 100644
--- a/dev-ruby/bcrypt-ruby/ChangeLog
+++ b/dev-ruby/bcrypt-ruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/bcrypt-ruby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/ChangeLog,v 1.12 2013/01/16 01:11:39 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/ChangeLog,v 1.13 2013/05/14 17:59:20 graaff Exp $
+
+ 14 May 2013; Hans de Graaff <graaff@gentoo.org> bcrypt-ruby-3.0.1.ebuild,
+ +files/bcrypt-ruby-3.0.1-undefined-symbols.patch:
+ Remove unused code triggering unused symbols, bug 469690.
16 Jan 2013; Rick Farina <zerochaos@gentoo.org> bcrypt-ruby-3.0.1.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.0.1.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.0.1.ebuild
index b8ee157550e5..179acbf6c8e6 100644
--- a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.0.1.ebuild
+++ b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.0.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.0.1.ebuild,v 1.12 2013/01/16 01:11:39 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.0.1.ebuild,v 1.13 2013/05/14 17:59:20 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 ree18"
+USE_RUBY="ruby18 ruby19"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -21,6 +21,8 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-ma
SLOT="0"
IUSE=""
+RUBY_PATCHES=( ${P}-undefined-symbols.patch )
+
all_ruby_prepare() {
rm Gemfile || die
sed -i -e '/git ls-files/d' bcrypt-ruby.gemspec || die
diff --git a/dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch b/dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch
new file mode 100644
index 000000000000..37abf2624c02
--- /dev/null
+++ b/dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch
@@ -0,0 +1,42 @@
+commit 94f8d0ae95ed773cb9e31a71e4046d3b97e11d70
+Author: Aman Gupta <aman@tmm1.net>
+Date: Sat Mar 30 19:52:19 2013 -0700
+
+ remove last of TBR code (fixes #46)
+
+diff --git a/ext/mri/bcrypt_ext.c b/ext/mri/bcrypt_ext.c
+index cce35df..13f5e4e 100644
+--- a/ext/mri/bcrypt_ext.c
++++ b/ext/mri/bcrypt_ext.c
+@@ -4,31 +4,6 @@
+ static VALUE mBCrypt;
+ static VALUE cBCryptEngine;
+
+-#ifdef RUBY_VM
+-# define RUBY_1_9
+-#endif
+-
+-#ifdef RUBY_1_9
+-
+-/* When on Ruby 1.9+, we will want to unlock the GIL while performing
+- * expensive calculations, for greater concurrency. Do not do this for
+- * cheap calculations because locking/unlocking the GIL incurs some overhead as well.
+- */
+-#define GIL_UNLOCK_COST_THRESHOLD 9
+-
+-typedef struct {
+- char *output;
+- const char *key;
+- const char *salt;
+-} BCryptArguments;
+-
+-static VALUE bcrypt_wrapper(void *_args) {
+- BCryptArguments *args = (BCryptArguments *)_args;
+- return (VALUE)ruby_bcrypt(args->output, args->key, args->salt);
+-}
+-
+-#endif /* RUBY_1_9 */
+-
+ /* Given a logarithmic cost parameter, generates a salt for use with +bc_crypt+.
+ */
+ static VALUE bc_salt(VALUE self, VALUE prefix, VALUE count, VALUE input) {