summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-01-07 22:16:38 +0000
committerAron Griffis <agriffis@gentoo.org>2003-01-07 22:16:38 +0000
commit7e6c17f2bf1971827081f59df4f69700f22b2fb5 (patch)
tree8f3f01bc5db3cc02753d043215adda936e7e077b /dev-ruby/amstd/amstd-2.0.0.ebuild
parentAdded mips to keywords (diff)
downloadgentoo-2-7e6c17f2bf1971827081f59df4f69700f22b2fb5.tar.gz
gentoo-2-7e6c17f2bf1971827081f59df4f69700f22b2fb5.tar.bz2
gentoo-2-7e6c17f2bf1971827081f59df4f69700f22b2fb5.zip
Update to 2.0.0
Diffstat (limited to 'dev-ruby/amstd/amstd-2.0.0.ebuild')
-rw-r--r--dev-ruby/amstd/amstd-2.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/amstd/amstd-2.0.0.ebuild b/dev-ruby/amstd/amstd-2.0.0.ebuild
new file mode 100644
index 000000000000..ce5c2e698b06
--- /dev/null
+++ b/dev-ruby/amstd/amstd-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amstd/amstd-2.0.0.ebuild,v 1.1 2003/01/07 22:16:38 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ruby utility collection by Minero Aoki"
+SRC_URI="http://www.loveruby.net/archive/amstd/${P}.tar.gz"
+HOMEPAGE="http://www.loveruby.net/en/amstd.html"
+LICENSE="LGPL"
+KEYWORDS="x86 alpha"
+SLOT="0"
+
+DEPEND=">=dev-lang/ruby-1.6.1"
+
+src_compile() {
+ ruby install.rb config || die
+ ruby install.rb setup || die
+}
+
+src_install () {
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install
+}