summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-04-10 06:49:07 +0000
committerMamoru Komachi <usata@gentoo.org>2004-04-10 06:49:07 +0000
commitd99401c3ba9fd20701501f3672d2d6fcc5db86a2 (patch)
tree9f3e9303b8bf564e91f15e98d302b845512e5ab1 /dev-ruby/amrita
parentTypo Fix (Manifest recommit) (diff)
downloadgentoo-2-d99401c3ba9fd20701501f3672d2d6fcc5db86a2.tar.gz
gentoo-2-d99401c3ba9fd20701501f3672d2d6fcc5db86a2.tar.bz2
gentoo-2-d99401c3ba9fd20701501f3672d2d6fcc5db86a2.zip
virtual/ruby fix, see bug #46968
Diffstat (limited to 'dev-ruby/amrita')
-rw-r--r--dev-ruby/amrita/ChangeLog6
-rw-r--r--dev-ruby/amrita/amrita-1.0.2.ebuild10
-rw-r--r--dev-ruby/amrita/amrita-1.8.2-r1.ebuild21
-rw-r--r--dev-ruby/amrita/amrita-1.8.2.ebuild7
4 files changed, 23 insertions, 21 deletions
diff --git a/dev-ruby/amrita/ChangeLog b/dev-ruby/amrita/ChangeLog
index 832c22e8ee2a..f0aebe57d32c 100644
--- a/dev-ruby/amrita/ChangeLog
+++ b/dev-ruby/amrita/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/amrita
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/ChangeLog,v 1.7 2004/03/18 21:35:00 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/ChangeLog,v 1.8 2004/04/10 06:49:07 usata Exp $
+
+ 10 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> amrita-1.0.2.ebuild,
+ amrita-1.8.2-r1.ebuild, amrita-1.8.2.ebuild:
+ virtual/ruby fix, see bug #46968
24 Feb 2004; Ciaran McCreesh <ciaranm@gentoo.org> amrita-1.8.2.ebuild:
Stable on sparc
diff --git a/dev-ruby/amrita/amrita-1.0.2.ebuild b/dev-ruby/amrita/amrita-1.0.2.ebuild
index bc97fe02a8aa..7bda657750d0 100644
--- a/dev-ruby/amrita/amrita-1.0.2.ebuild
+++ b/dev-ruby/amrita/amrita-1.0.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/amrita-1.0.2.ebuild,v 1.4 2004/02/24 22:28:22 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/amrita-1.0.2.ebuild,v 1.5 2004/04/10 06:49:07 usata Exp $
+
+inherit ruby
DESCRIPTION="A HTML/XHTML template library for Ruby"
HOMEPAGE="http://www.brain-tokyo.jp/research/amrita/index.html"
@@ -8,8 +10,10 @@ SRC_URI="http://www.brain-tokyo.jp/research/amrita/${P}.tar.gz"
LICENSE="Ruby"
SLOT="0"
KEYWORDS="alpha hppa mips sparc x86"
-DEPEND=">=dev-lang/ruby-1.6.7
- >=dev-ruby/strscan-0.6.5"
+USE_RUBY="ruby16 ruby18 ruby19"
+DEPEND="|| ( >=dev-lang/ruby-1.8
+ dev-ruby/shim-ruby18
+ dev-lang/ruby-cvs )"
src_install() {
local sitelibdir=`ruby -r rbconfig -e 'print(Config::CONFIG["sitelibdir"])'`
diff --git a/dev-ruby/amrita/amrita-1.8.2-r1.ebuild b/dev-ruby/amrita/amrita-1.8.2-r1.ebuild
index 043a02f40422..159e166677aa 100644
--- a/dev-ruby/amrita/amrita-1.8.2-r1.ebuild
+++ b/dev-ruby/amrita/amrita-1.8.2-r1.ebuild
@@ -1,23 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/amrita-1.8.2-r1.ebuild,v 1.3 2004/02/24 22:28:22 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/amrita-1.8.2-r1.ebuild,v 1.4 2004/04/10 06:49:07 usata Exp $
+
+inherit ruby
DESCRIPTION="A HTML/XHTML template library for Ruby"
HOMEPAGE="http://www.brain-tokyo.jp/research/amrita/index.html"
SRC_URI="http://www.brain-tokyo.jp/research/amrita/${P}.tar.gz"
LICENSE="Ruby"
SLOT="0"
+USE_RUBY="ruby16 ruby18 ruby19"
KEYWORDS="~alpha ~hppa ~mips ~sparc ~x86"
-DEPEND=">=dev-lang/ruby-1.8.0"
-
-src_compile() {
- ruby install.rb config --prefix=/usr || die
- ruby install.rb setup || die
-}
-
-src_install() {
- ruby install.rb config --prefix=${D}/usr || die
- ruby install.rb install || die
- dodoc ChangeLog README* RELEASENOTE
- dohtml -r docs/html/*
-}
+DEPEND="|| ( >=dev-lang/ruby-1.8.0
+ dev-ruby/shim-ruby18
+ dev-lang/ruby-cvs )"
diff --git a/dev-ruby/amrita/amrita-1.8.2.ebuild b/dev-ruby/amrita/amrita-1.8.2.ebuild
index d1e3f3d5b56d..8149647af5ec 100644
--- a/dev-ruby/amrita/amrita-1.8.2.ebuild
+++ b/dev-ruby/amrita/amrita-1.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/amrita-1.8.2.ebuild,v 1.7 2004/02/24 22:28:22 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amrita/amrita-1.8.2.ebuild,v 1.8 2004/04/10 06:49:07 usata Exp $
DESCRIPTION="A HTML/XHTML template library for Ruby"
HOMEPAGE="http://www.brain-tokyo.jp/research/amrita/index.html"
@@ -9,8 +9,9 @@ LICENSE="Ruby"
SLOT="0"
KEYWORDS="~alpha hppa ~mips sparc x86"
IUSE=""
-DEPEND=">=dev-lang/ruby-1.6.7
- >=dev-ruby/strscan-0.6.5"
+DEPEND="|| ( >=dev-lang/ruby-1.8.0
+ dev-ruby/shim-ruby18
+ dev-lang/ruby-cvs )"
src_compile() {
ruby install.rb config --prefix=/usr || die