summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-13 19:15:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-13 19:15:52 +0000
commit9e4e1ddcd03e7cc5fee2367e49d3591282db0b62 (patch)
treef7b456614022f2c086ab9135cf1b4e2b579fadd5 /dev-ruby/amazon-ec2
parentMissing gtk-update-icon-cache. (diff)
downloadgentoo-2-9e4e1ddcd03e7cc5fee2367e49d3591282db0b62.tar.gz
gentoo-2-9e4e1ddcd03e7cc5fee2367e49d3591282db0b62.tar.bz2
gentoo-2-9e4e1ddcd03e7cc5fee2367e49d3591282db0b62.zip
Generate documentation using YARD rather than RDoc as the options hashes aren't documented very well otherwise.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/amazon-ec2')
-rw-r--r--dev-ruby/amazon-ec2/ChangeLog7
-rw-r--r--dev-ruby/amazon-ec2/amazon-ec2-0.9.4.ebuild19
2 files changed, 14 insertions, 12 deletions
diff --git a/dev-ruby/amazon-ec2/ChangeLog b/dev-ruby/amazon-ec2/ChangeLog
index 2511fe7ca86b..335baf07b99d 100644
--- a/dev-ruby/amazon-ec2/ChangeLog
+++ b/dev-ruby/amazon-ec2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/amazon-ec2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amazon-ec2/ChangeLog,v 1.2 2010/02/12 21:57:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amazon-ec2/ChangeLog,v 1.3 2010/02/13 19:15:52 flameeyes Exp $
+
+ 13 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ amazon-ec2-0.9.4.ebuild:
+ Generate documentation using YARD rather than RDoc as the options hashes
+ aren't documented very well otherwise.
*amazon-ec2-0.9.4 (12 Feb 2010)
diff --git a/dev-ruby/amazon-ec2/amazon-ec2-0.9.4.ebuild b/dev-ruby/amazon-ec2/amazon-ec2-0.9.4.ebuild
index be97c9348d0d..67e2977e85c0 100644
--- a/dev-ruby/amazon-ec2/amazon-ec2-0.9.4.ebuild
+++ b/dev-ruby/amazon-ec2/amazon-ec2-0.9.4.ebuild
@@ -1,21 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amazon-ec2/amazon-ec2-0.9.4.ebuild,v 1.1 2010/02/12 21:57:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amazon-ec2/amazon-ec2-0.9.4.ebuild,v 1.2 2010/02/13 19:15:52 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 jruby"
-# dev-ruby/yard can be used instead of rdoc, but since the output only
-# differs in style and adds one further dependency, we'll just go with
-# rdoc for now.
-#
-# In case, the configuration would be
-# RUBY_FAKEGEM_TASK_DOC="yard"
-# RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.rdoc README_dev.rdoc ChangeLog"
RUBY_FAKEGEM_BINWRAP="ec2sh"
@@ -30,6 +22,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+# We only need yard for Ruby 1.8, as we use it for documentation
+# generation.
+USE_RUBY=ruby18 \
+ ruby_add_bdepend doc "dev-ruby/yard"
+
ruby_add_bdepend test "virtual/ruby-test-unit dev-ruby/test-spec dev-ruby/mocha"
ruby_add_rdepend '>=dev-ruby/xml-simple-1.0.12'