summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-15 07:45:29 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-15 07:45:29 +0000
commitf7bce9ca4e8f4b8267917a45a26b5d5bfce50aa9 (patch)
tree6dcdadc4ed0bc72611b96243b26684ef96b6fda4 /dev-ruby/activesupport
parentMake sure the build system uses the right toolchain binaries, bug #340795 by ... (diff)
downloadgentoo-2-f7bce9ca4e8f4b8267917a45a26b5d5bfce50aa9.tar.gz
gentoo-2-f7bce9ca4e8f4b8267917a45a26b5d5bfce50aa9.tar.bz2
gentoo-2-f7bce9ca4e8f4b8267917a45a26b5d5bfce50aa9.zip
Version bump for rails 2.3.10.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog8
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.10.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 6585057e3875..b90ee7e730d5 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.125 2010/09/29 22:27:33 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.126 2010/10/15 07:45:29 graaff Exp $
+
+*activesupport-2.3.10 (15 Oct 2010)
+
+ 15 Oct 2010; Hans de Graaff <graaff@gentoo.org>
+ +activesupport-2.3.10.ebuild:
+ Version bump for rails 2.3.10.
29 Sep 2010; Brent Baude <ranger@gentoo.org> activesupport-2.3.8.ebuild:
Marking activesupport-2.3.8 ~ppc64 for bug 322175
diff --git a/dev-ruby/activesupport/activesupport-2.3.10.ebuild b/dev-ruby/activesupport/activesupport-2.3.10.ebuild
new file mode 100644
index 000000000000..28286bcb7d16
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.10.ebuild,v 1.1 2010/10/15 07:45:29 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as
+ # well as fixing the dependencies for i18n to use the correct
+ # slot.
+ epatch "${FILESDIR}"/${PN}-2.3.9-unvendorize.patch
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}