summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-06 19:29:15 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-06 19:29:15 +0000
commitb6479d2f40ec0e1c8bb3f7af257c91a1fd0f89a7 (patch)
tree8bc5e3892eadad3c5a30a1c67a7e00e801c73c2d /dev-ruby/activesupport
parentFix linking on Solaris (diff)
downloadgentoo-2-b6479d2f40ec0e1c8bb3f7af257c91a1fd0f89a7.tar.gz
gentoo-2-b6479d2f40ec0e1c8bb3f7af257c91a1fd0f89a7.tar.bz2
gentoo-2-b6479d2f40ec0e1c8bb3f7af257c91a1fd0f89a7.zip
Version bump for Rails 4.0.5, security bug 509706.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-4.0.5.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 9f083acd584c..0b29d63eb9ed 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.254 2014/05/06 18:50:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.255 2014/05/06 19:29:15 graaff Exp $
+
+*activesupport-4.0.5 (06 May 2014)
+
+ 06 May 2014; Hans de Graaff <graaff@gentoo.org> +activesupport-4.0.5.ebuild:
+ Version bump for Rails 4.0.5, security bug 509706.
*activesupport-3.2.18 (06 May 2014)
diff --git a/dev-ruby/activesupport/activesupport-4.0.5.ebuild b/dev-ruby/activesupport/activesupport-4.0.5.ebuild
new file mode 100644
index 000000000000..f411273dd64e
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.0.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.0.5.ebuild,v 1.1 2014/05/06 19:29:15 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.3:0
+ >=dev-ruby/i18n-0.6.9:0.6
+ >=dev-ruby/tzinfo-0.3.37:0
+ >=dev-ruby/minitest-4.2:0
+ >=dev-ruby/thread_safe-0.1:0
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure a compatible version of minitest is used everywhere.
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 4.2'/" lib/active_support/test_case.rb || die
+ sed -i -e "1igem 'minitest', '~> 4.2'" test/abstract_unit.rb || die
+}