summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-04 09:23:58 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-04 09:23:58 +0000
commit5790f93c6f739f40b4982219673639f44af8c05d (patch)
tree0fd4888097e844d932a3ec0e83aab0c91cebf80c /dev-ruby/activesupport
parentAdd ~ppc keyword for 0.6 slot which was most likely the intention when keywor... (diff)
downloadgentoo-2-5790f93c6f739f40b4982219673639f44af8c05d.tar.gz
gentoo-2-5790f93c6f739f40b4982219673639f44af8c05d.tar.bz2
gentoo-2-5790f93c6f739f40b4982219673639f44af8c05d.zip
Version bump for security bug 406547.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.12.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 63c9b57e2775..c9ae9d64f085 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.165 2012/03/11 13:50:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.166 2012/04/04 09:23:58 graaff Exp $
+
+*activesupport-3.0.12 (04 Apr 2012)
+
+ 04 Apr 2012; Hans de Graaff <graaff@gentoo.org> +activesupport-3.0.12.ebuild:
+ Version bump for security bug 406547.
11 Mar 2012; Brent Baude <ranger@gentoo.org> activesupport-3.1.3.ebuild:
Marking activesupport-3.1.3 ~ppc64 for bug 396043
diff --git a/dev-ruby/activesupport/activesupport-3.0.12.ebuild b/dev-ruby/activesupport/activesupport-3.0.12.ebuild
new file mode 100644
index 000000000000..ef9333ced88e
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.12.ebuild,v 1.1 2012/04/04 09:23:58 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}