summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-28 07:20:53 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-28 07:20:53 +0000
commit0d48e7f43bcded9f2317f8b3b7150f88143c1376 (patch)
tree1ea5949b883bdfd49265cdd3b72d4c71ce169f8b /dev-ruby/activesupport
parentcmake variable LIB was renamed to GMXLIB (diff)
downloadgentoo-2-0d48e7f43bcded9f2317f8b3b7150f88143c1376.tar.gz
gentoo-2-0d48e7f43bcded9f2317f8b3b7150f88143c1376.tar.bz2
gentoo-2-0d48e7f43bcded9f2317f8b3b7150f88143c1376.zip
Version bump for Rails 3.0.10
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-3.0.10.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index ed5a5893eb9d..ed7692cd0994 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.153 2011/09/09 07:37:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.154 2011/09/28 07:20:53 graaff Exp $
+
+*activesupport-3.0.10 (28 Sep 2011)
+
+ 28 Sep 2011; Hans de Graaff <graaff@gentoo.org> +activesupport-3.0.10.ebuild:
+ Version bump for Rails 3.0.10
09 Sep 2011; Fabian Groffen <grobian@gentoo.org>
activesupport-3.0.9.ebuild:
diff --git a/dev-ruby/activesupport/activesupport-3.0.10.ebuild b/dev-ruby/activesupport/activesupport-3.0.10.ebuild
new file mode 100644
index 000000000000..ecd93d5d8b9c
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-3.0.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-3.0.10.ebuild,v 1.1 2011/09/28 07:20:53 graaff Exp $
+
+EAPI=4
+
+# jruby fails tests.
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+SRC_URI="https://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/${PN}"
+
+ruby_add_rdepend ">=dev-ruby/memcache-client-1.5.8"
+
+# libxml-ruby and nokogiri are not strictly needed, but there are tests
+# using this code.
+ruby_add_bdepend "test? ( virtual/ruby-test-unit >=dev-ruby/libxml-2.0.0 dev-ruby/nokogiri )"
+
+all_ruby_prepare() {
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-3.0.3-mocha-0.9.5.patch
+
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+}