summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-04 09:26:55 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-04 09:26:55 +0000
commite8d25c425e3163d5b76e96493d0a125350b654ac (patch)
treef0df1cbdb85be72177a529ef80f65e1f7829d49b /dev-ruby/activeresource
parentVersion bump for security bug 406547. (diff)
downloadgentoo-2-e8d25c425e3163d5b76e96493d0a125350b654ac.tar.gz
gentoo-2-e8d25c425e3163d5b76e96493d0a125350b654ac.tar.bz2
gentoo-2-e8d25c425e3163d5b76e96493d0a125350b654ac.zip
Version bump for security bug 406547.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.0.12.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index b8f3d53da328..34ea21113c0b 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.104 2012/03/11 13:51:07 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.105 2012/04/04 09:26:55 graaff Exp $
+
+*activeresource-3.0.12 (04 Apr 2012)
+
+ 04 Apr 2012; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.0.12.ebuild:
+ Version bump for security bug 406547.
11 Mar 2012; Brent Baude <ranger@gentoo.org> activeresource-3.1.3.ebuild:
Marking activeresource-3.1.3 ~ppc64 for bug 396177
diff --git a/dev-ruby/activeresource/activeresource-3.0.12.ebuild b/dev-ruby/activeresource/activeresource-3.0.12.ebuild
new file mode 100644
index 000000000000..e84ab30ed41e
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.0.12.ebuild,v 1.1 2012/04/04 09:26:55 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activeresource"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+}