summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-05 09:18:15 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-05 09:18:15 +0000
commitbd8f179b1e5687a22fd447eaad789d0f4868ea4d (patch)
treed1f12d2259d24a4ae66a89fdb0b9419a89ed7795 /dev-ruby/activerecord
parentVersion bump for Rails 2.3.9 (diff)
downloadgentoo-2-bd8f179b1e5687a22fd447eaad789d0f4868ea4d.tar.gz
gentoo-2-bd8f179b1e5687a22fd447eaad789d0f4868ea4d.tar.bz2
gentoo-2-bd8f179b1e5687a22fd447eaad789d0f4868ea4d.zip
Version bump for Rails 2.3.9
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.9.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index d0bd9cfd19a8..1cd2b4f32284 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.137 2010/08/15 19:21:00 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.138 2010/09/05 09:18:15 graaff Exp $
+
+*activerecord-2.3.9 (05 Sep 2010)
+
+ 05 Sep 2010; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.9.ebuild:
+ Version bump for Rails 2.3.9
15 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
activerecord-2.3.8-r1.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-2.3.9.ebuild b/dev-ruby/activerecord/activerecord-2.3.9.ebuild
new file mode 100644
index 000000000000..e95c976b8117
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.9.ebuild,v 1.1 2010/09/05 09:18:15 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+USE_RUBY=ruby18 \
+ ruby_add_rdepend "
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( dev-ruby/pg )"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ !dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+
+ epatch "${FILESDIR}/${PN}-2.3.8-add-index-with-symbol.patch"
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+#
+# if use sqlite; then
+# ${RUBY} -S rake test_sqlite || die "sqlite3 tests failed"
+# fi
+}