summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-09-04 06:25:13 +0000
committerHans de Graaff <graaff@gentoo.org>2009-09-04 06:25:13 +0000
commita4bf607522e31a5d202e09b5fdf36ac63cf7c561 (patch)
tree329b04eb66118cc57efe75283611018d3a379812 /dev-ruby/activerecord
parentremove old (diff)
downloadgentoo-2-a4bf607522e31a5d202e09b5fdf36ac63cf7c561.tar.gz
gentoo-2-a4bf607522e31a5d202e09b5fdf36ac63cf7c561.tar.bz2
gentoo-2-a4bf607522e31a5d202e09b5fdf36ac63cf7c561.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.4.ebuild22
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 40fd237dd7d4..3dfa124df88b 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.105 2009/07/22 07:08:10 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.106 2009/09/04 06:25:13 graaff Exp $
+
+*activerecord-2.3.4 (04 Sep 2009)
+
+ 04 Sep 2009; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.3.4.ebuild:
+ Version bump: fix security issues reported in #283396.
*activerecord-2.3.3 (22 Jul 2009)
diff --git a/dev-ruby/activerecord/activerecord-2.3.4.ebuild b/dev-ruby/activerecord/activerecord-2.3.4.ebuild
new file mode 100644
index 000000000000..fd4a6a0d9359
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.4.ebuild,v 1.1 2009/09/04 06:25:13 graaff Exp $
+
+inherit ruby gems
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+
+DEPEND=">=dev-lang/ruby-1.8.6
+ ~dev-ruby/activesupport-2.3.4"
+RDEPEND="${DEPEND}
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"