summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-10-05 17:55:57 +0000
committerHans de Graaff <graaff@gentoo.org>2011-10-05 17:55:57 +0000
commit8121cc931641349a1d06af73ce1825b93c992868 (patch)
treedf52aec29bb1983afd5003614f1e7365fb1b852d /dev-ruby/activerecord
parentppc stable wrt #369909 (diff)
downloadgentoo-2-8121cc931641349a1d06af73ce1825b93c992868.tar.gz
gentoo-2-8121cc931641349a1d06af73ce1825b93c992868.tar.bz2
gentoo-2-8121cc931641349a1d06af73ce1825b93c992868.zip
Remove old versions.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog6
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.7.ebuild61
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.9.ebuild61
3 files changed, 5 insertions, 123 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index d79e12b0f02b..7fb8c44d6519 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.172 2011/09/28 07:52:39 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.173 2011/10/05 17:55:57 graaff Exp $
+
+ 05 Oct 2011; Hans de Graaff <graaff@gentoo.org> -activerecord-3.0.7.ebuild,
+ -activerecord-3.0.9.ebuild:
+ Remove old versions.
28 Sep 2011; Hans de Graaff <graaff@gentoo.org> -activerecord-2.3.5.ebuild,
-activerecord-2.3.11.ebuild, -activerecord-2.3.12.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-3.0.7.ebuild b/dev-ruby/activerecord/activerecord-3.0.7.ebuild
deleted file mode 100644
index 8bc98d2c97ab..000000000000
--- a/dev-ruby/activerecord/activerecord-3.0.7.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.7.ebuild,v 1.4 2011/07/04 09:36:31 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-S="${WORKDIR}/rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.0.2:2.0
- >=dev-ruby/tzinfo-0.3.23
- sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
- mysql? ( dev-ruby/mysql2:0.2 )
- postgres? ( dev-ruby/pg )"
-
-ruby_add_bdepend "
- test? (
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-ruby-1.3.3
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.0.9.ebuild b/dev-ruby/activerecord/activerecord-3.0.9.ebuild
deleted file mode 100644
index bd3ad785c8d0..000000000000
--- a/dev-ruby/activerecord/activerecord-3.0.9.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.9.ebuild,v 1.4 2011/09/09 08:33:21 grobian Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-S="${WORKDIR}/rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.0.10-r1:2.0
- >=dev-ruby/tzinfo-0.3.23
- sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
- mysql? ( dev-ruby/mysql2:0.2 )
- postgres? ( dev-ruby/pg )"
-
-ruby_add_bdepend "
- test? (
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-ruby-1.3.3
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}