summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-05-23 10:37:02 +0000
committerAlex Legler <a3li@gentoo.org>2010-05-23 10:37:02 +0000
commit78a06efa863afa7196bd85ab4558651280c0c0cd (patch)
treeab2ad19ea8f1b67682b118cbd8c90f82d37e4b82 /dev-ruby/activerecord
parentAdd REE18 support (diff)
downloadgentoo-2-78a06efa863afa7196bd85ab4558651280c0c0cd.tar.gz
gentoo-2-78a06efa863afa7196bd85ab4558651280c0c0cd.tar.bz2
gentoo-2-78a06efa863afa7196bd85ab4558651280c0c0cd.zip
Add REE18 support
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog5
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 537b182d9ec1..a6418a5aca1e 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.133 2010/05/22 14:59:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.134 2010/05/23 10:37:02 a3li Exp $
+
+ 23 May 2010; Alex Legler <a3li@gentoo.org> activerecord-2.3.5-r1.ebuild:
+ Add REE18 support
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
activerecord-2.3.5.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild b/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild
index d98bd1a02db6..dc6c28cedc76 100644
--- a/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild
+++ b/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild,v 1.8 2010/02/13 20:44:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild,v 1.9 2010/05/23 10:37:02 a3li Exp $
EAPI=2
-USE_RUBY="ruby18 jruby"
+USE_RUBY="ruby18 ree18 jruby"
# this is not null so that the dependencies will actually be filled
RUBY_FAKEGEM_TASK_TEST="none"
@@ -21,7 +21,7 @@ SLOT="2.3"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="mysql postgres sqlite3" #sqlite
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+ruby_add_rdepend "~dev-ruby/activesupport-${PV} >=dev-ruby/activesupport-${PV}-r1"
#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
USE_RUBY=ruby18 ruby_add_rdepend "ruby_targets_ruby18 sqlite3" "dev-ruby/sqlite3-ruby"