summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-11-07 10:14:03 +0000
committerHans de Graaff <graaff@gentoo.org>2014-11-07 10:14:03 +0000
commit3f62a032ba04bef141af886dbeeb240b7301f4d9 (patch)
treef1fdc8449ef4168571614b666ab841fe716a8069 /dev-ruby/activerecord
parentRemove vulnerable versions. (diff)
downloadgentoo-2-3f62a032ba04bef141af886dbeeb240b7301f4d9.tar.gz
gentoo-2-3f62a032ba04bef141af886dbeeb240b7301f4d9.tar.bz2
gentoo-2-3f62a032ba04bef141af886dbeeb240b7301f4d9.zip
Remove vulnerable versions.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.19.ebuild75
-rw-r--r--dev-ruby/activerecord/activerecord-4.0.10.ebuild80
-rw-r--r--dev-ruby/activerecord/activerecord-4.0.9.ebuild80
-rw-r--r--dev-ruby/activerecord/activerecord-4.1.5.ebuild76
-rw-r--r--dev-ruby/activerecord/activerecord-4.1.6.ebuild76
6 files changed, 6 insertions, 388 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 166d6827fd8e..2beeabeaa9d7 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.280 2014/10/31 08:58:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.281 2014/11/07 10:14:03 graaff Exp $
+
+ 07 Nov 2014; Hans de Graaff <graaff@gentoo.org> -activerecord-3.2.19.ebuild,
+ -activerecord-4.0.9.ebuild, -activerecord-4.0.10.ebuild,
+ -activerecord-4.1.5.ebuild, -activerecord-4.1.6.ebuild:
+ Remove vulnerable versions.
*activerecord-4.1.7 (31 Oct 2014)
*activerecord-4.0.11 (31 Oct 2014)
diff --git a/dev-ruby/activerecord/activerecord-3.2.19.ebuild b/dev-ruby/activerecord/activerecord-3.2.19.ebuild
deleted file mode 100644
index ec7b3100127f..000000000000
--- a/dev-ruby/activerecord/activerecord-3.2.19.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.19.ebuild,v 1.2 2014/08/16 16:19:50 blueness Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-3.0.2:3.0
- >=dev-ruby/tzinfo-0.3.29:0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- dev-ruby/mocha:0.13
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|nokogiri\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-# sed -i -e '/[Bb]undler/d' ../load_paths.rb || die
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Avoid tests depending on hash ordering
- sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-
- # Avoid test depending on specific sqlite3 binding or database version.
- sed -i -e '/test_uniqueness_violations_are_translated/,/^ end/ s:^:#:' test/cases/adapter_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -I. -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-4.0.10.ebuild b/dev-ruby/activerecord/activerecord-4.0.10.ebuild
deleted file mode 100644
index 285e3517f035..000000000000
--- a/dev-ruby/activerecord/activerecord-4.0.10.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.0.10.ebuild,v 1.1 2014/09/12 05:56:01 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/activerecord-deprecated_finders-1.0.2:1.0
- >=dev-ruby/arel-4.0.2:4.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )
- !<dev-ruby/protected_attributes-1.0.8"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- dev-ruby/mocha:0.13
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-
- # Avoid single test using mysql dependencies.
- rm test/cases/invalid_connection_test.rb || die
-
- # Avoid test depending on specific sqlite3 binding or database version.
- sed -i -e '/test_uniqueness_violations_are_translated/,/^ end/ s:^:#:' test/cases/adapter_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-4.0.9.ebuild b/dev-ruby/activerecord/activerecord-4.0.9.ebuild
deleted file mode 100644
index e516e6fd2743..000000000000
--- a/dev-ruby/activerecord/activerecord-4.0.9.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.0.9.ebuild,v 1.1 2014/08/18 22:18:42 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/activerecord-deprecated_finders-1.0.2:1.0
- >=dev-ruby/arel-4.0.2:4.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.5 )
- mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )
- !<dev-ruby/protected_attributes-1.0.8"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- dev-ruby/mocha:0.13
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-
- # Avoid single test using mysql dependencies.
- rm test/cases/invalid_connection_test.rb || die
-
- # Avoid test depending on specific sqlite3 binding or database version.
- sed -i -e '/test_uniqueness_violations_are_translated/,/^ end/ s:^:#:' test/cases/adapter_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-4.1.5.ebuild b/dev-ruby/activerecord/activerecord-4.1.5.ebuild
deleted file mode 100644
index 7d52bffd87bc..000000000000
--- a/dev-ruby/activerecord/activerecord-4.1.5.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.1.5.ebuild,v 1.1 2014/08/18 22:18:42 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-5.0.0:5.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.6 )
- mysql? ( >=dev-ruby/mysql2-0.3.13:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- dev-ruby/mocha:0.13
- <dev-ruby/minitest-5.3.4:5
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\)/ s:^:#:" ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-
- # Avoid single test using mysql dependencies.
- rm test/cases/invalid_connection_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-4.1.6.ebuild b/dev-ruby/activerecord/activerecord-4.1.6.ebuild
deleted file mode 100644
index 8f4b0fb3178b..000000000000
--- a/dev-ruby/activerecord/activerecord-4.1.6.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-4.1.6.ebuild,v 1.1 2014/09/12 06:27:45 graaff Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-5.0.0:5.0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.6 )
- mysql? ( >=dev-ruby/mysql2-0.3.13:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.5
- dev-ruby/mocha:0.13
- <dev-ruby/minitest-5.3.4:5
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\)/ s:^:#:" ../Gemfile || die
- sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
-
- sed -i -e '/bcrypt/ s/3.0.0/3.0/' ../Gemfile || die
-
- # Add back json in the Gemfile because we dropped some dependencies
- # earlier that implicitly required it.
- sed -i -e '$agem "json"' ../Gemfile || die
-
- # Avoid test depending on mysql adapter which we don't support for
- # this Rails version to simplify our dependencies.
- rm test/cases/connection_specification/resolver_test.rb || die
-
- # Avoid single test using mysql dependencies.
- rm test/cases/invalid_connection_test.rb || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}