summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-01 07:05:08 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-01 07:05:08 +0000
commit071bc691093f715da27fc3edeeaabbda57bdd6a9 (patch)
treeb914705efbee93e0c99eb686e63ac5e93644835c /dev-ruby/activemodel
parentVersion bump for bug 418481. (diff)
downloadgentoo-2-071bc691093f715da27fc3edeeaabbda57bdd6a9.tar.gz
gentoo-2-071bc691093f715da27fc3edeeaabbda57bdd6a9.tar.bz2
gentoo-2-071bc691093f715da27fc3edeeaabbda57bdd6a9.zip
Version bump for bug 418481.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.5.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 3181f1223eec..a11e5b497c4d 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.27 2012/06/01 06:11:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.28 2012/06/01 07:05:08 graaff Exp $
+
+*activemodel-3.2.5 (01 Jun 2012)
+
+ 01 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.5.ebuild:
+ Version bump for bug 418481.
01 Jun 2012; Hans de Graaff <graaff@gentoo.org> -activemodel-3.0.10.ebuild,
-activemodel-3.0.11.ebuild:
diff --git a/dev-ruby/activemodel/activemodel-3.2.5.ebuild b/dev-ruby/activemodel/activemodel-3.2.5.ebuild
new file mode 100644
index 000000000000..f46a38891892
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.5.ebuild,v 1.1 2012/06/01 07:05:08 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}