summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 12:22:38 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 12:22:38 +0000
commit8319d9b32c92f08f0da392dc422637877fdbc866 (patch)
treefc02a25e202db44a7ecf5a446f8d14e46ec016f7 /dev-ruby/actionwebservice
parentAdd xdg-utils to RDEPEND, spotted by Bailey Kong <bailey@tgpsolutions.com> in... (diff)
downloadgentoo-2-8319d9b32c92f08f0da392dc422637877fdbc866.tar.gz
gentoo-2-8319d9b32c92f08f0da392dc422637877fdbc866.tar.bz2
gentoo-2-8319d9b32c92f08f0da392dc422637877fdbc866.zip
Version bump, switch to panztel gem. We really need to get some compatibility support as the las three versions have different authors (and gem names).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionwebservice')
-rw-r--r--dev-ruby/actionwebservice/ChangeLog10
-rw-r--r--dev-ruby/actionwebservice/actionwebservice-2.3.5.ebuild46
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/actionwebservice/ChangeLog b/dev-ruby/actionwebservice/ChangeLog
index 894df2448bf9..a295c5e1d523 100644
--- a/dev-ruby/actionwebservice/ChangeLog
+++ b/dev-ruby/actionwebservice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/actionwebservice
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionwebservice/ChangeLog,v 1.75 2010/01/04 11:05:10 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionwebservice/ChangeLog,v 1.76 2010/01/13 12:22:38 flameeyes Exp $
+
+*actionwebservice-2.3.5 (13 Jan 2010)
+
+ 13 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +actionwebservice-2.3.5.ebuild:
+ Version bump, switch to panztel gem. We really need to get some
+ compatibility support as the las three versions have different authors
+ (and gem names).
04 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
actionwebservice-2.3.4.ebuild:
diff --git a/dev-ruby/actionwebservice/actionwebservice-2.3.5.ebuild b/dev-ruby/actionwebservice/actionwebservice-2.3.5.ebuild
new file mode 100644
index 000000000000..e06926633002
--- /dev/null
+++ b/dev-ruby/actionwebservice/actionwebservice-2.3.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionwebservice/actionwebservice-2.3.5.ebuild,v 1.1 2010/01/13 12:22:38 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+MY_OWNER="panztel"
+
+RUBY_FAKEGEM_NAME="${MY_OWNER}-${PN}"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README TODO"
+
+RUBY_FAKEGEM_EXTRAINSTALL="generators"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Support for Web Services APIs for Rails"
+HOMEPAGE="http://github.com/${MY_OWNER}/${PN}"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/actionpack-2.3*
+ =dev-ruby/activerecord-2.3*"
+
+# it uses activerecord when running tests, but they don't work so
+# ignore them for now.
+#ruby_add_bdepend test 'dev-ruby/sqlite3-ruby'
+RESTRICT=test
+
+each_ruby_install() {
+ each_fakegem_install
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ pushd examples
+ insinto /usr/share/doc/${PF}/examples
+ doins -r *
+ popd
+}