summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 11:40:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 11:40:21 +0000
commite6141e66c821a89ac777f8dd06447cbb33084aaa (patch)
tree2b7e8ba2cf5d80d68336bac4124fbee781bae46a /dev-ruby/actionmailer
parent[app-misc/mc] version bump to 4.7.0.1 (diff)
downloadgentoo-2-e6141e66c821a89ac777f8dd06447cbb33084aaa.tar.gz
gentoo-2-e6141e66c821a89ac777f8dd06447cbb33084aaa.tar.bz2
gentoo-2-e6141e66c821a89ac777f8dd06447cbb33084aaa.zip
Port to ruby-fakegem.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog8
-rw-r--r--dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index ffe2fa86e39e..8425326280f0 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.130 2010/01/04 10:57:10 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.131 2010/01/13 11:40:21 flameeyes Exp $
+
+*actionmailer-2.3.5-r1 (13 Jan 2010)
+
+ 13 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +actionmailer-2.3.5-r1.ebuild:
+ Port to ruby-fakegem.
04 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
actionmailer-2.3.5.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild b/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild
new file mode 100644
index 000000000000..44cf3ac2f8b6
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-2.3.5-r1.ebuild,v 1.1 2010/01/13 11:40:21 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/text-format-0.6.3
+ >=dev-ruby/tmail-1.2.3"
+ruby_add_bdepend test ">=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}