summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-17 09:27:29 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-17 09:27:29 +0000
commit74b2d615e99b8199a152237ea7586a07842e562c (patch)
treeb6223ec808bf905ce2446473455b0def8ee4cc0a /dev-ruby/actionmailer
parentVersion bump for Rails 3.1.6. (diff)
downloadgentoo-2-74b2d615e99b8199a152237ea7586a07842e562c.tar.gz
gentoo-2-74b2d615e99b8199a152237ea7586a07842e562c.tar.bz2
gentoo-2-74b2d615e99b8199a152237ea7586a07842e562c.zip
Version bump for Rails 3.1.6.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.1.6.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index aa2648cebd20..50ba37d0f289 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.190 2012/06/13 17:42:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.191 2012/06/17 09:27:29 graaff Exp $
+
+*actionmailer-3.1.6 (17 Jun 2012)
+
+ 17 Jun 2012; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.1.6.ebuild:
+ Version bump for Rails 3.1.6.
*actionmailer-3.0.15 (13 Jun 2012)
diff --git a/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild b/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild
new file mode 100644
index 000000000000..4e7bc8c2078e
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.1.6.ebuild,v 1.1 2012/06/17 09:27:29 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.3.3:2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
+}