summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-23 07:14:20 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-23 07:14:20 +0000
commitaccbfafec3c197a237a81de6dfc1de0bb0bc6894 (patch)
tree187f713e1e6be21ff9e4446739556d594d0c6ff4 /dev-ruby/RubyInline
parentVersion bump. (diff)
downloadgentoo-2-accbfafec3c197a237a81de6dfc1de0bb0bc6894.tar.gz
gentoo-2-accbfafec3c197a237a81de6dfc1de0bb0bc6894.tar.bz2
gentoo-2-accbfafec3c197a237a81de6dfc1de0bb0bc6894.zip
Version bump.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/RubyInline')
-rw-r--r--dev-ruby/RubyInline/ChangeLog7
-rw-r--r--dev-ruby/RubyInline/RubyInline-3.12.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/RubyInline/ChangeLog b/dev-ruby/RubyInline/ChangeLog
index 855e20a70f4d..87b8ab700228 100644
--- a/dev-ruby/RubyInline/ChangeLog
+++ b/dev-ruby/RubyInline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/RubyInline
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.5 2013/01/15 06:01:46 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/ChangeLog,v 1.6 2013/02/23 07:14:20 graaff Exp $
+
+*RubyInline-3.12.1 (23 Feb 2013)
+
+ 23 Feb 2013; Hans de Graaff <graaff@gentoo.org> +RubyInline-3.12.1.ebuild:
+ Version bump.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> RubyInline-3.11.3.ebuild,
RubyInline-3.11.4.ebuild, RubyInline-3.8.6.ebuild:
diff --git a/dev-ruby/RubyInline/RubyInline-3.12.1.ebuild b/dev-ruby/RubyInline/RubyInline-3.12.1.ebuild
new file mode 100644
index 000000000000..d5a4fe856d26
--- /dev/null
+++ b/dev-ruby/RubyInline/RubyInline-3.12.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/RubyInline/RubyInline-3.12.1.ebuild,v 1.1 2013/02/23 07:14:20 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend dev-ruby/zentest
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ virtual/ruby-minitest
+ )"
+
+RUBY_PATCHES=(
+ ruby-inline-3.11.0-gentoo.patch
+ ruby-inline-3.11.1-ldflags.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}