summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-02-27 21:57:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-02-27 21:57:45 +0000
commitfef9ac6e1893cda684dc847cc1af2d3aac6c256f (patch)
treed36ea8700c8b8900482d163e6bcc62b20fd140d4 /dev-python
parentadd CC-BY-NC-ND-3.0 license (diff)
downloadgentoo-2-fef9ac6e1893cda684dc847cc1af2d3aac6c256f.tar.gz
gentoo-2-fef9ac6e1893cda684dc847cc1af2d3aac6c256f.tar.bz2
gentoo-2-fef9ac6e1893cda684dc847cc1af2d3aac6c256f.zip
Version bump. Switch to python-r1 framework. Re-organize SpaceFuncs to make it work
(Portage version: 2.2.01.21688-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oosuite/ChangeLog11
-rw-r--r--dev-python/oosuite/metadata.xml2
-rw-r--r--dev-python/oosuite/oosuite-0.38.ebuild96
-rw-r--r--dev-python/oosuite/oosuite-0.39.ebuild95
-rw-r--r--dev-python/oosuite/oosuite-0.43.ebuild109
5 files changed, 119 insertions, 194 deletions
diff --git a/dev-python/oosuite/ChangeLog b/dev-python/oosuite/ChangeLog
index e21158408175..b363ada4269b 100644
--- a/dev-python/oosuite/ChangeLog
+++ b/dev-python/oosuite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/oosuite
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oosuite/ChangeLog,v 1.6 2012/11/01 19:30:56 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oosuite/ChangeLog,v 1.7 2013/02/27 21:57:45 bicatali Exp $
+
+*oosuite-0.43 (27 Feb 2013)
+
+ 27 Feb 2013; Sébastien Fabbro <bicatali@gentoo.org> +oosuite-0.43.ebuild,
+ -oosuite-0.38.ebuild, -oosuite-0.39.ebuild, metadata.xml:
+ Version bump. Switch to python-r1 framework. Re-organize SpaceFuncs to make it
+ work
*oosuite-0.42 (01 Nov 2012)
diff --git a/dev-python/oosuite/metadata.xml b/dev-python/oosuite/metadata.xml
index 291eba128960..0db43e9d5520 100644
--- a/dev-python/oosuite/metadata.xml
+++ b/dev-python/oosuite/metadata.xml
@@ -4,7 +4,7 @@
<herd>sci-mathematics</herd>
<longdescription lang='en'>
The OpenOpt suite of Python packages contains the following modules:
- * OpenOpt: universal numerical optimization package with
+ * openopt: universal numerical optimization package with
several solvers (e.g. ralg) and connections to tens of other,
graphical output of convergence.
* FuncDesigner: tool to rapidly build functions over
diff --git a/dev-python/oosuite/oosuite-0.38.ebuild b/dev-python/oosuite/oosuite-0.38.ebuild
deleted file mode 100644
index e5b0d83a3adc..000000000000
--- a/dev-python/oosuite/oosuite-0.38.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oosuite/oosuite-0.38.ebuild,v 1.2 2012/10/19 04:46:28 patrick Exp $
-
-EAPI=4
-
-# python eclass cruft
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_USE_WITH="tk?"
-RESTRICT_PYTHON_ABIS="2.4 2.7-pypy-* *-jython 3.3"
-
-inherit distutils eutils
-
-MYPN="OOSuite"
-MYPID="f/f3"
-
-DESCRIPTION="OpenOpt suite of Python modules for numerical optimization"
-HOMEPAGE="http://openopt.org/"
-SRC_URI="http://openopt.org/images/${MYPID}/${MYPN}.zip -> ${MYPN}-${PV}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples minimal tk"
-
-RDEPEND="dev-python/numpy
- !minimal? (
- dev-python/cvxopt[glpk]
- dev-python/lp_solve
- dev-python/matplotlib
- dev-python/setproctitle
- sci-libs/nlopt[python]
- sci-libs/scipy )"
-DEPEND="app-arch/unzip
- dev-python/numpy
- dev-python/setuptools"
-
-S="${WORKDIR}/PythonPackages"
-
-src_prepare() {
- #epatch "${FILESDIR}"/${PN}-0.37-no-init-msg.patch
- OO_DIRS="DerApproximator FuncDesigner OpenOpt SpaceFuncs"
- find . -name "*COPYING*" -delete
- # move all examples and tests to ease installation in proper directory
- mkdir "${WORKDIR}/examples"
- local d e
- for d in ${OO_DIRS}; do
- mkdir "${WORKDIR}/examples/${d}"
- for e in $(find ${d} -type d -name examples -or -name tests -or -name doc); do
- mv ${e} "${WORKDIR}/examples/${d}/" || die
- done
- done
-}
-
-src_compile() {
- local d
- for d in ${OO_DIRS}; do
- pushd ${d} > /dev/null
- distutils_src_compile
- popd > /dev/null
- done
-}
-
-src_test() {
- testing() {
- local d t oldpath=${PYTHONPATH}
- for d in ${OO_DIRS}; do
- PYTHONPATH="${S}/${d}/build-${PYTHON_ABI}/lib:${PYTHONPATH}"
- done
- export PYTHONPATH
- cd "${WORKDIR}"/examples
- for t in \
- DerApproximator/tests/t_check.py \
- FuncDesigner/examples/sle1.py \
- OpenOpt/examples/nlp_1.py \
- SpaceFuncs/examples/triangle.py
- do
- "$(PYTHON)" ${t}
- done
- export PYTHONPATH=${oldpath}
- }
- python_execute_function testing
-}
-
-src_install() {
- local d
- for d in ${OO_DIRS}; do
- pushd ${d} > /dev/null
- distutils_src_install
- popd > /dev/null
- done
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/examples
- fi
-}
diff --git a/dev-python/oosuite/oosuite-0.39.ebuild b/dev-python/oosuite/oosuite-0.39.ebuild
deleted file mode 100644
index 6e7cbce16ab6..000000000000
--- a/dev-python/oosuite/oosuite-0.39.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oosuite/oosuite-0.39.ebuild,v 1.3 2012/10/19 04:46:28 patrick Exp $
-
-EAPI=4
-
-# python eclass cruft
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_USE_WITH="tk?"
-RESTRICT_PYTHON_ABIS="2.4 2.7-pypy-* *-jython 3.3"
-
-inherit distutils eutils
-
-MYPN="OOSuite"
-MYPID="f/f3"
-
-DESCRIPTION="OpenOpt suite of Python modules for numerical optimization"
-HOMEPAGE="http://openopt.org/"
-SRC_URI="http://openopt.org/images/${MYPID}/${MYPN}.zip -> ${MYPN}-${PV}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples minimal tk"
-
-RDEPEND="dev-python/numpy
- !minimal? (
- dev-python/cvxopt[glpk]
- dev-python/lp_solve
- dev-python/matplotlib
- dev-python/setproctitle
- sci-libs/nlopt[python]
- sci-libs/scipy )"
-DEPEND="app-arch/unzip
- dev-python/numpy
- dev-python/setuptools"
-
-S="${WORKDIR}/PythonPackages"
-
-src_prepare() {
- OO_DIRS="DerApproximator FuncDesigner OpenOpt SpaceFuncs"
- find . -name "*COPYING*" -delete
- # move all examples and tests to ease installation in proper directory
- mkdir "${WORKDIR}/examples"
- local d e
- for d in ${OO_DIRS}; do
- mkdir "${WORKDIR}/examples/${d}"
- for e in $(find ${d} -type d -name examples -or -name tests -or -name doc); do
- mv ${e} "${WORKDIR}/examples/${d}/" || die
- done
- done
-}
-
-src_compile() {
- local d
- for d in ${OO_DIRS}; do
- pushd ${d} > /dev/null
- distutils_src_compile
- popd > /dev/null
- done
-}
-
-src_test() {
- testing() {
- local d t oldpath=${PYTHONPATH}
- for d in ${OO_DIRS}; do
- PYTHONPATH="${S}/${d}/build-${PYTHON_ABI}/lib:${PYTHONPATH}"
- done
- export PYTHONPATH
- cd "${WORKDIR}"/examples
- for t in \
- DerApproximator/tests/t_check.py \
- FuncDesigner/examples/sle1.py \
- OpenOpt/examples/nlp_1.py \
- SpaceFuncs/examples/triangle.py
- do
- "$(PYTHON)" ${t}
- done
- export PYTHONPATH=${oldpath}
- }
- python_execute_function testing
-}
-
-src_install() {
- local d
- for d in ${OO_DIRS}; do
- pushd ${d} > /dev/null
- distutils_src_install
- popd > /dev/null
- done
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/examples
- fi
-}
diff --git a/dev-python/oosuite/oosuite-0.43.ebuild b/dev-python/oosuite/oosuite-0.43.ebuild
new file mode 100644
index 000000000000..8f6bde5a5eeb
--- /dev/null
+++ b/dev-python/oosuite/oosuite-0.43.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oosuite/oosuite-0.43.ebuild,v 1.1 2013/02/27 21:57:45 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_REQ_USE='tk?'
+
+inherit distutils-r1 eutils
+
+MYPN="OOSuite"
+MYPID="f/f3"
+
+DESCRIPTION="OpenOpt suite of Python modules for numerical optimization"
+HOMEPAGE="http://openopt.org/"
+SRC_URI="http://openopt.org/images/${MYPID}/${MYPN}.zip -> ${MYPN}-${PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples minimal tk"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ !minimal? (
+ dev-python/cvxopt[glpk,${PYTHON_USEDEP}]
+ dev-python/lp_solve[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ sci-libs/nlopt[python]
+ sci-libs/scipy[${PYTHON_USEDEP}] )"
+DEPEND="
+ app-arch/unzip
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/PythonPackages"
+
+OO_DIRS="DerApproximator FuncDesigner OpenOpt SpaceFuncs"
+
+python_prepare() {
+ # reorganize SpaceFuncs
+ pushd SpaceFuncs > /dev/null
+ mkdir SpaceFuncs
+ cp __version__.py SpaceFuncs || die
+ mv SpaceFuncs.py __init__.py kernel SpaceFuncs || die
+ popd > /dev/null
+ local d
+ for d in ${OO_DIRS}; do
+ pushd ${d} > /dev/null
+ find . -name "*COPYING*" -delete
+ find . -type d -name examples -or -name tests -or -name doc \
+ -exec rm -r '{}' +
+ distutils-r1_python_prepare
+ popd > /dev/null
+ done
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # move all examples and tests to ease installation in proper directory
+ mkdir "${WORKDIR}/examples"
+ local d e
+ for d in ${OO_DIRS}; do
+ mkdir "${WORKDIR}/examples/${d}" || die
+ for e in $(find ${d} -type d -name examples -or -name tests -or -name doc); do
+ mv ${e} "${WORKDIR}/examples/${d}/" || die
+ done
+ done
+}
+
+python_compile() {
+ local d
+ for d in ${OO_DIRS}; do
+ pushd ${d} > /dev/null
+ distutils-r1_python_compile
+ popd > /dev/null
+ done
+}
+
+python_test() {
+ local d t oldpath=${PYTHONPATH}
+ for d in ${OO_DIRS}; do
+ PYTHONPATH="${BUILD_DIR}/${d}/build/lib:${PYTHONPATH}"
+ done
+ export PYTHONPATH
+ cd "${WORKDIR}"/examples
+ # limit the tests, other need more dependencies
+ for t in \
+ DerApproximator/tests/t_check.py \
+ FuncDesigner/examples/sle1.py \
+ OpenOpt/examples/nlp_1.py \
+ SpaceFuncs/examples/triangle.py
+ do
+ "${PYTHON}" ${t} || die "test ${t} failed"
+ done
+ export PYTHONPATH=${oldpath}
+}
+
+python_install() {
+ local d
+ for d in ${OO_DIRS}; do
+ pushd ${d} > /dev/null
+ distutils-r1_python_install
+ popd > /dev/null
+ done
+ use examples && EXAMPLES="${WORKDIR}"/examples
+}