summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-02-01 17:42:22 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-02-01 17:42:22 +0000
commitf9909238297ebf9614299160ed476958e8d14c3c (patch)
tree301ea6e613fc554182121ad2eec278d2e7d80df3 /dev-python
parentAdjust Qt4 deps a bit (diff)
downloadgentoo-2-f9909238297ebf9614299160ed476958e8d14c3c.tar.gz
gentoo-2-f9909238297ebf9614299160ed476958e8d14c3c.tar.bz2
gentoo-2-f9909238297ebf9614299160ed476958e8d14c3c.zip
Revbump which changes installation paths according to upstream recommendations. Thanks to Davide Pesavento
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog9
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.2-r1.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index 89710d5b4905..f924016d672d 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.52 2010/01/21 21:14:04 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.53 2010/02/01 17:42:22 hwoarang Exp $
+
+*qscintilla-python-2.4.2-r1 (01 Feb 2010)
+
+ 01 Feb 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qscintilla-python-2.4.2-r1.ebuild:
+ Revbump which changes installation paths according to upstream
+ recommendations. Thanks to Davide Pesavento
*qscintilla-python-2.4.2 (21 Jan 2010)
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.2-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..62735a4c880f
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.2-r1.ebuild,v 1.1 2010/02/01 17:42:22 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEFINE_DEFAULT_FUNCTIONS="1"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python toolchain-funcs
+
+MY_P="QScintilla-gpl-${PV/_pre/-snapshot-}"
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.co.uk/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND=">=dev-python/sip-4.10
+ >=dev-python/PyQt4-4.7[X]
+ ~x11-libs/qscintilla-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/Python"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4-nostrip.patch
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ local myconf="$(PYTHON) configure.py -p 4
+ --destdir=$(python_get_sitedir)/PyQt4
+ $(use debug && echo '--debug')"
+ echo ${myconf}
+ ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ building() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)"
+ }
+ python_execute_function -s building
+}