summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-10-30 09:57:16 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-10-30 09:57:16 +0000
commitee590750e08044643ad4000c05d5269342e9bcf3 (patch)
tree7948f5d49558ec3faef86a1b748574e647f7000c /dev-python
parentAs for sys-libs/pam, add pam-syntax PDEPEND with vim-syntax package present. (diff)
downloadgentoo-2-ee590750e08044643ad4000c05d5269342e9bcf3.tar.gz
gentoo-2-ee590750e08044643ad4000c05d5269342e9bcf3.tar.bz2
gentoo-2-ee590750e08044643ad4000c05d5269342e9bcf3.zip
Fix bug #147285, eautomake invocation needed, see ebuild for full details.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygobject/ChangeLog6
-rw-r--r--dev-python/pygobject/pygobject-2.12.2.ebuild13
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 1e36fc907d20..13a1108debae 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.6 2006/10/13 15:03:50 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.7 2006/10/30 09:57:16 robbat2 Exp $
+
+ 30 Oct 2006; Robin H. Johnson <robbat2@gentoo.org>
+ pygobject-2.12.2.ebuild:
+ Fix bug #147285, eautomake invocation needed, see ebuild for full details.
*pygobject-2.12.2 (13 Oct 2006)
diff --git a/dev-python/pygobject/pygobject-2.12.2.ebuild b/dev-python/pygobject/pygobject-2.12.2.ebuild
index 5fb6f1e75908..42f6536307ad 100644
--- a/dev-python/pygobject/pygobject-2.12.2.ebuild
+++ b/dev-python/pygobject/pygobject-2.12.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.12.2.ebuild,v 1.2 2006/10/21 22:32:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.12.2.ebuild,v 1.3 2006/10/30 09:57:16 robbat2 Exp $
-inherit gnome2 python eutils
+inherit gnome2 python eutils autotools
DESCRIPTION="GNOME 2 bindings for Python"
HOMEPAGE="http://www.pygtk.org/"
@@ -21,13 +21,22 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+
pkg_setup() {
G2CONF="$(use_enable doc docs)"
}
+WANT_AUTOMAKE=1.8
+
src_unpack() {
gnome2_src_unpack
+ # fix bug #147285 - Robin H. Johnson <robbat2@gentoo.org>
+ # this is caused by upstream's automake-1.8 lacking some Gentoo-specific
+ # patches (for tmpfs amongst other things). Upstreams hit by this should
+ # move to newer automake versions ideally.
+ eautomake
+
# disable pyc compiling
mv py-compile py-compile.orig
ln -s /bin/true py-compile