summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-20 21:05:06 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-20 21:05:06 +0000
commited5cb46422a355fb6b3ba304b7e6c09fa0ebc5e3 (patch)
treeffd87774fe63dbf0c9594af721f2741b6199d365 /dev-python
parentVersion bump. Remove old (diff)
downloadgentoo-2-ed5cb46422a355fb6b3ba304b7e6c09fa0ebc5e3.tar.gz
gentoo-2-ed5cb46422a355fb6b3ba304b7e6c09fa0ebc5e3.tar.bz2
gentoo-2-ed5cb46422a355fb6b3ba304b7e6c09fa0ebc5e3.zip
dev-python/mpmath: Bump EAPI to 4, fix testing, #422593
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/mpmath/ChangeLog8
-rw-r--r--dev-python/mpmath/metadata.xml18
-rw-r--r--dev-python/mpmath/mpmath-0.16.ebuild20
-rw-r--r--dev-python/mpmath/mpmath-0.17.ebuild22
4 files changed, 45 insertions, 23 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index 60deb8970bf1..8432ea3fddc4 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mpmath
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.19 2011/05/18 21:04:30 grozin Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.20 2012/06/20 21:05:06 jlec Exp $
+
+ 20 Jun 2012; Justin Lecher <jlec@gentoo.org> mpmath-0.16.ebuild,
+ mpmath-0.17.ebuild, metadata.xml:
+ Bump EAPI to 4, fix testing, #422593
18 May 2011; Andrey Grozin <grozin@gentoo.org> mpmath-0.17.ebuild:
Fixing prefix-related bug #367461, thanks to Steven Trogdon
diff --git a/dev-python/mpmath/metadata.xml b/dev-python/mpmath/metadata.xml
index 38d6f0883ef6..ade8696b3c48 100644
--- a/dev-python/mpmath/metadata.xml
+++ b/dev-python/mpmath/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<maintainer>
- <email>grozin@gentoo.org</email>
- <name>Andrey Grozin</name>
-</maintainer>
-<longdescription lang='en'>
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription lang="en">
A Python library for arbitrary-precision floating-point arithmetic
</longdescription>
-<use>
- <flag name='matplotlib'>Add support for <pkg>dev-python/matplotlib</pkg></flag>
-</use>
+ <use>
+ <flag name="matplotlib">Add support for <pkg>dev-python/matplotlib</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/dev-python/mpmath/mpmath-0.16.ebuild b/dev-python/mpmath/mpmath-0.16.ebuild
index 12de58afb134..bf20aeff23bc 100644
--- a/dev-python/mpmath/mpmath-0.16.ebuild
+++ b/dev-python/mpmath/mpmath-0.16.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.16.ebuild,v 1.4 2010/11/10 17:56:07 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.16.ebuild,v 1.5 2012/06/20 21:05:06 jlec Exp $
+
+EAPI=4
-EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
@@ -12,7 +13,8 @@ inherit distutils
DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
HOMEPAGE="http://code.google.com/p/mpmath/ http://pypi.python.org/pypi/mpmath"
-SRC_URI="http://mpmath.googlecode.com/files/${P}.tar.gz
+SRC_URI="
+ http://mpmath.googlecode.com/files/${P}.tar.gz
doc? ( http://mpmath.googlecode.com/files/${PN}-docsrc-${PV}.tar.gz )"
LICENSE="BSD"
@@ -20,7 +22,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
IUSE="doc examples gmp matplotlib"
-RDEPEND="gmp? ( dev-python/gmpy )
+RDEPEND="
+ gmp? ( dev-python/gmpy )
matplotlib? ( dev-python/matplotlib )"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
@@ -46,8 +49,11 @@ src_compile() {
}
src_test() {
- cd mpmath/tests
- distutils_src_test
+ testing() {
+ cd "${S}"/mpmath/tests
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
}
src_install() {
diff --git a/dev-python/mpmath/mpmath-0.17.ebuild b/dev-python/mpmath/mpmath-0.17.ebuild
index c290390a53dd..a62110fe3ef3 100644
--- a/dev-python/mpmath/mpmath-0.17.ebuild
+++ b/dev-python/mpmath/mpmath-0.17.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.17.ebuild,v 1.2 2011/05/18 21:04:30 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.17.ebuild,v 1.3 2012/06/20 21:05:06 jlec Exp $
+
+EAPI=4
-EAPI="3"
PYTHON_DEPEND="*:2.5"
SUPPORT_PYTHON_ABIS="1"
DISTUTILS_SRC_TEST="py.test"
@@ -11,6 +12,7 @@ inherit distutils eutils
MY_PN=${PN}-all
MY_P=${MY_PN}-${PV}
+
DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
HOMEPAGE="http://code.google.com/p/mpmath/ http://pypi.python.org/pypi/mpmath"
SRC_URI="http://mpmath.googlecode.com/files/${MY_P}.tar.gz"
@@ -20,14 +22,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
IUSE="doc examples gmp matplotlib"
-RDEPEND="gmp? ( dev-python/gmpy )
+RDEPEND="
+ gmp? ( dev-python/gmpy )
matplotlib? ( dev-python/matplotlib )"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
-DOCS="CHANGES"
S="${WORKDIR}/${MY_P}"
+DOCS="CHANGES"
+
src_prepare() {
distutils_src_prepare
@@ -52,6 +56,14 @@ src_compile() {
fi
}
+src_test() {
+ testing() {
+ cd "${S}"/mpmath/tests
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install