summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-09-04 03:51:30 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-09-04 03:51:30 +0000
commite6e7572d17af7931a41971be2c67ab004ee3312d (patch)
tree0b84434083927b6a4beabd1469bd1b4e9ad54804 /dev-python
parentMasked pycrypto pending freeze. (diff)
downloadgentoo-2-e6e7572d17af7931a41971be2c67ab004ee3312d.tar.gz
gentoo-2-e6e7572d17af7931a41971be2c67ab004ee3312d.tar.bz2
gentoo-2-e6e7572d17af7931a41971be2c67ab004ee3312d.zip
New package.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pycrypto/ChangeLog9
-rw-r--r--dev-python/pycrypto/files/digest-pycrypto-1.9_alpha41
-rw-r--r--dev-python/pycrypto/pycrypto-1.9_alpha4.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pycrypto/ChangeLog b/dev-python/pycrypto/ChangeLog
new file mode 100644
index 000000000000..12481cb0c29a
--- /dev/null
+++ b/dev-python/pycrypto/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/pycrypto
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/ChangeLog,v 1.1 2002/09/04 03:51:30 agenkin Exp $
+
+*pycrypto-1.9_alpha4 (03 Sep 2002)
+
+ 03 May 2002; Arcady Genkin <agenkin@thpoon.com> pycrypto-1.9_alpha4 :
+
+ Initial version.
diff --git a/dev-python/pycrypto/files/digest-pycrypto-1.9_alpha4 b/dev-python/pycrypto/files/digest-pycrypto-1.9_alpha4
new file mode 100644
index 000000000000..0fb903755436
--- /dev/null
+++ b/dev-python/pycrypto/files/digest-pycrypto-1.9_alpha4
@@ -0,0 +1 @@
+MD5 bff31078a531c8fc617c01fe72aacfbb pycrypto-1.9a4.tar.gz 143415
diff --git a/dev-python/pycrypto/pycrypto-1.9_alpha4.ebuild b/dev-python/pycrypto/pycrypto-1.9_alpha4.ebuild
new file mode 100644
index 000000000000..6244dbf07b1e
--- /dev/null
+++ b/dev-python/pycrypto/pycrypto-1.9_alpha4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2002 Arcady Genkin <agenkin@thpoon.com>
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycrypto/pycrypto-1.9_alpha4.ebuild,v 1.1 2002/09/04 03:51:30 agenkin Exp $
+
+DESCRIPTION="Python cryptography toolkit."
+HOMEPAGE="http://www.amk.ca/python/code/crypto.html"
+LICENSE="freedist"
+
+DEPEND="virtual/glibc
+ dev-lang/python"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+KEYWORDS="x86"
+SRC_URI="http://www.amk.ca/files/python/${P/_alpha/a}.tar.gz"
+
+S="${WORKDIR}/${P/_alpha/a}"
+
+src_compile() {
+ python setup.py build || die
+}
+
+src_install () {
+ python setup.py install --root=${D} --prefix=/usr || die
+ dodoc ACKS ChangeLog LICENSE MANIFEST PKG-INFO README TODO
+}