summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-08 18:40:41 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-08 18:40:41 +0000
commite415668ca1bd82f789f243d4addc6bbe34d9024f (patch)
treefdfed301b2eb2ea91120415d7ad9d31c0e40ebb5 /dev-python
parentCleanup (diff)
downloadgentoo-2-e415668ca1bd82f789f243d4addc6bbe34d9024f.tar.gz
gentoo-2-e415668ca1bd82f789f243d4addc6bbe34d9024f.tar.bz2
gentoo-2-e415668ca1bd82f789f243d4addc6bbe34d9024f.zip
Introduce a snapshot ebuild to get the Python3.3 support. Update homepage.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nose/ChangeLog8
-rw-r--r--dev-python/nose/nose-1.2.1_p2012.ebuild86
-rw-r--r--dev-python/nose/nose-9999.ebuild4
3 files changed, 95 insertions, 3 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index cc94b694b993..58112f4869c0 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.90 2013/01/02 20:54:55 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.91 2013/01/08 18:40:41 mgorny Exp $
+
+*nose-1.2.1_p2012 (08 Jan 2013)
+
+ 08 Jan 2013; Michał Górny <mgorny@gentoo.org> +nose-1.2.1_p2012.ebuild,
+ nose-9999.ebuild:
+ Introduce a snapshot ebuild to get the Python3.3 support. Update homepage.
02 Jan 2013; Michał Górny <mgorny@gentoo.org> nose-1.2.1.ebuild:
Restrict python3.3 due to failures (again).
diff --git a/dev-python/nose/nose-1.2.1_p2012.ebuild b/dev-python/nose/nose-1.2.1_p2012.ebuild
new file mode 100644
index 000000000000..54b1df9bee87
--- /dev/null
+++ b/dev-python/nose/nose-1.2.1_p2012.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.2.1_p2012.ebuild,v 1.1 2013/01/08 18:40:41 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9,2_0} )
+inherit distutils-r1 eutils vcs-snapshot
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://github.com/nose-devs/nose"
+SRC_URI="https://github.com/nose-devs/${PN}/archive/e879960507d51a.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )
+ test? ( dev-python/twisted )"
+
+DOCS=( AUTHORS )
+
+python_prepare_all() {
+ # Tests need to be converted, and they don't respect BUILD_DIR.
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+
+ # Disable sphinx.ext.intersphinx, requires network
+ epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/test_resolve/_&/g" \
+ -e "s/test_raises_bad_return/_&/g" \
+ -e "s/test_raises_twisted_error/_&/g" \
+ -i unit_tests/test_twisted.py || die "sed failed"
+ # Disable versioning of nosetests script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
+ -i setup.py || die "sed2 failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local add_targets=()
+
+ if use test; then
+ add_targets+=( egg_info )
+ [[ ${EPYTHON} == python3* ]] && add_targets+=( build_tests )
+ fi
+
+ distutils-r1_python_compile ${add_targets[@]}
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+src_test() {
+ # nosetests use heavy multiprocessing during the tests.
+ # this shall make them less likely to kill your system or timeout.
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${PYTHON}" selftest.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install --install-data "${EPREFIX}/usr/share"
+}
+
+python_install_all() {
+ if use doc; then
+ dohtml -r -A txt doc/.build/html/*
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/nose/nose-9999.ebuild b/dev-python/nose/nose-9999.ebuild
index f4105b7db7ca..5c737386afdf 100644
--- a/dev-python/nose/nose-9999.ebuild
+++ b/dev-python/nose/nose-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-9999.ebuild,v 1.1 2013/01/02 12:28:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-9999.ebuild,v 1.2 2013/01/08 18:40:41 mgorny Exp $
EAPI=5
@@ -14,7 +14,7 @@ PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9,2_0} )
inherit distutils-r1 eutils
DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
-HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://bitbucket.org/jpellerin/nose"
+HOMEPAGE="http://pypi.python.org/pypi/nose http://readthedocs.org/docs/nose/ https://github.com/nose-devs/nose"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"